Kaspersky
Question

[3820261]Firewall apps rules: impossible to add new app to a subgroup (existing or new) [Plan publish fix in 2020 patch G Dec. 9]

  • 8 November 2019
  • 43 replies
  • 11811 views

Win 10pro/64-1909; after installing NIS, I added to the firewall some apps new rules and everything was ok, the firewall allowing to make changes without any special user confirmation; I also added new trustworthy subgroups and related apps to be ruled, this operation also led without any problem. From yesterday  I found that something has changed, when I try to apply a new rule to an app a pop up ask me for “user confirmation……….”; also, and this is really strange and worrying, the insertion of a new app  is not allowed (NIS firewall opens the window to make the app (.exe) choice, but then nothing is added to the subgroup). What has happened? I don’t think it’s virus related, after making a deep scan nothing suspect was found

Please help


43 replies

Userlevel 2

Hello,

 

This is the Bug 3820261: [SUPPORT][HIPS] Cannot add application to group

Our developers are analyzing it now.

 

The bug reproduces on my PC. So, I think it is some general issue, which will be fixed soon.

I will keep you informed.

 

Thank you.

 

 

Userlevel 2

Hello,

 

The bug will be fixed in patch G, which will be published on servers after the 29-th of November 2019.

 

Thank you.

Userlevel 2

Hello,

I have just tested subgroup creation via Firewall → Configure application rules and via Application Control → Manage Applications with patch G installed. All works fine. Subgroups are creating in both sections.

Sib3riX seems has another issue and should follow to Flood instructions.

Thank you.

Userlevel 7
Badge +6

Hello  @Sib3riX,

Hmmm, yes, I understand, now :thumbsup_tone3:

The Clean Up has never before pushed a UAC prompt, neither should it, it’s not a change…. 

FW add, I’ll test tomorrow, not that I need to really, now you’ve confirmed. 

PIA, means, data collection, logging it with the Lab etc:confounded:

Let me know if you get any feedback? 

I’ll do the same. 

Thank you:pray_tone3:

 

Userlevel 2

@FLOOD  Exactly this is my problem. UAC pop up everytime i try to add something to trusted in firewall or use  KTS, Manage Applications, Clean up.

 

Please send me the number of your incident.

 

Thank you.

Userlevel 7
Badge +6

Hello @momo,

You’re welcome!

When you work (again) with the Lab, give them videos & images and an opportunity to help solve the issue. 

Others (in the Community) may have had a similar issue, if they see your post, I’m sure they’ll reply to you, however, keep in mind, not all problems that “appear”  the same, have the same root cause.

You’ve identified a number of issues, a proper analysis and trouble shooting procedures need to be done and that can take time.

Best regards. 

Userlevel 2

@FLOOD  Exactly this is my problem. UAC pop up everytime i try to add something to trusted in firewall or use  KTS, Manage Applications, Clean up.

 

UAC pop up is same as yours in picture number 2

Userlevel 2

Patch is still not up but im ok with that. Let them test patch before pushing to live version. I dont want more problems :D

KIS version: kis 20.0.14.1085 abcit_19847

Report annexed

I’m starting to try your suggestions

Thanks

I already uninstalled and reinstalled KIS; it worked correctly for some time, and then, don’t know why (maybe some app, I have many portable) , it starts to behave with the above issue. KIS is licensed and I already contacted the Tech Support, but they didn’t find any suggestion, at least till now; this is the reason why I annex anyway GSI & windows log, hoping in your help.

I annex a pict. of the pop up window asking for user confirmation and one of the “add app to the subgroup”, that opens the choice windows but didn’t charge it inside firewall

Thanks

Hello @momo,

Thank you for replying, the information and the Report. 

I’ll look at it.

One thing please; KIS patch letter, please confirm it for me?

Thank you.


Sorry for my ignorance, what is KIS patch letter? It should be E (I reinstalled kis 01/11 and always upated it) but I dont’know where to find its confirmation

Edit….found, I confirm it is E

Userlevel 7
Badge +6

Hello @momo,

Thank you for replying, the patch and the images.

  1. The Kaspersky “Attention, User Confirmation” popup is normal, so, are you saying, you’ve only recently started seeing AUC?
  2. I appreciate you have uninstalled/reinstalled KIS, however, I’d like you to follow the steps I’ve provided please? 
  3. For “one of the “add app to the subgroup”, that opens the choice windows but didn’t charge it inside firewall”, can you make a video of the issue for us please?

(I use CamStudio, is safe, easy to use & free, select: Region: Full Screen), or use any video software you’re comfortable with. 

  • When did you log the issue with the Lab? 

Thank you. 

Userlevel 7
Badge +6

Hello  @momo,

We experience the same frustration(s), not making excuses, oftentimes we’re impacted by the same issues; as Community members we do everything we can to help.

Best regards. 

Userlevel 7
Badge +4

please forgive my outburst.

 

No excuses of course, you are always welcome.

Userlevel 7
Badge +6

Hello   @Mikhail Shakhov,

I can see what @Sib3riX is concerned about:

(for example) KTS, Manage Applications, Clean up

 

:warning: UAC popup displays (that’s not normal)

  • Previous to patch g, selecting Clean up has never propmpted a UAC
  • Cancel UAC, don’t grant consent, GUI presents “List is up to date” 

 

:thinking:

 

Userlevel 2

Hello,

We are testing patch G now.

Planned publish date:

09.12.2019

Thank you.

 

Userlevel 2

Hello,

 

I`ve reproduced the “problem” with patch G and it reproduces with patch F as well. I think it by design and the “Clean up” button just was protected by our developers using Secure Desktop(it is not UAC).

 

I do not see the big problem here. You can create the request to support in order to get the confirmation from developers about this feature.

 

Thank you.

 

 

 

 

Userlevel 7
Badge +6

Hello  @Mikhail Shakhov ,

Why is it necessary for a simple function like “Clean up” to have require a UAC permission?

Clean up has no configurable options. 

& why is it necessary for us to seek confirmation from the developers for an unnecessary & unwelcome change made by Kaspersky? 

Thank you. 

Userlevel 2

Hello  @Mikhail Shakhov ,

Why is it necessary for a simple function like “Clean up” to have require a UAC permission?

Clean up has no configurable options. 

& why is it necessary for us to seek confirmation from the developers for an unnecessary change made by Kaspersky? 

Thank you. 

 

  1. This windows names “Secure Desktop”. It is not UAC. I can suppose, that it uses to make sure the customer makes these actions but not malware, for example.
  2. It is not necessary.
Userlevel 7
Badge +6

Hello @momo,

Welcome!

  • KIS version? & patch(x)? patch = letter
  • In KIS Reports, are there any relevant errors? If “yes”, export the Report and attach to your reply please? 

Without any data, it’s impossible to answer “ What has happened?”

  1. (My recommendation), reset KIS to default, shutdown device using Full shutdown, not Restart, recheck?
  2. If the issue persists, uninstall KIS,  shutdown device using Full shutdown, not Restart.
  3. Start device, login, dowload and install new KIS exe, shutdown device using Full shutdown, not Restart.
  4. Start device, login, start KIS, configure rules, recheck?
  5. If the problem persists and KIS is licensed, contact Kaspersky Lab Technical Support and ask them to help?

If KIS is unlicensed and the issue persists after 1 to 4, post back with GSI & Windows Logs, and images of the issue please? 

Thank you. 

Userlevel 7
Badge +6

Hello  @momo,

Thank you for replying, the information and the Report. 

I’ll look at it.

One thing please; KIS patch letter, please confirm it for me?

Thank you.

Userlevel 7
Badge +6

Hello  @Mikhail Shakhov 

This Attention (Kaspersky)

for the simple “Clean up” function,  surely the Kaspersky application has enough “smarts” to know “what” instigated the Clean up?

  1. Yes
  2. Yes, I’ll try, even if, as I told you, after reinstall, everything was working fine, no issues at all and no AUC
  3. Annexed (zip fro 7zip app) As you can see selecting the app Backupper.exe nothing is added inside AOMEI group. This worked after installation

I’m thinking to go back to 2019 vers. Do you have an offline link?

Sorry what do you mean with “ When did you log the issue with the Lab “

Userlevel 7
Badge +6

Hello @momo,

Thank you for posting again. 

I fully appreciate you’ve uninstalled/reinstalled.

  • I’d like you to follow steps 1 thru to 4, then monitor the issue. 

If it repeats, I’d like to know please?

  • When did you log the issue with the Lab? 
  • If you’d like to revert to 2019, please contact the Lab. 

Thank you

When did you log the issue with the Lab: do you mean when I contacted tech support?; first time last friday (1st november). But after reinstall everything was fine, as I told you, and they stopped supporting me. Today I sent them another request, but I don’t know my issue is still active (Italy).

About reinstall procedure, as I told you, I’ll try what you suggest, even if, after reinstall, everything was working fine, no issues at all and no AUC

Reply / Ответить