Kaspersky
Question

WSL rsync / ssh traffic slow down unless Kaspersky is paused

  • 4 December 2019
  • 4 replies
  • 5197 views

  • Once posted
  • 1 reply

Hi,

Windows 10 with WSL (Ubuntu for Windows) installed, I often use rsync via ssh to upload files to the internet. I noticed the upload speed is slowed down a lot, unless I pause Kaspersky.

I have tried adding the rsync.exe/ssh.exe and even all the exe under WSL as trusted applications and exclusions, but the upload speed is still slow. If I pause Kaspersky manually, then the speed is back to normal.

Is there something I can do about this?

Thanks!

 


4 replies

Userlevel 7
Badge +11

Hello  @PDD,

Welcome!

Please tell us: 

  1. Windows operating system version & build
  2. KAVF version & patch ?
  3. Is your system meeting hardware & software compability requirements
  4. WSL/Ubuntu version ? 
  5. Has the issue always existed? If “yes”, how long has KAVF been installed? If “no”, when did it start? In the 24hrs preceeding the issue, were there any software, hardware, network, environmental changes, anything at all? 
  6. Has a software compatibility check been performed? 
  7. Run a GSI & Windows logs, upload the zip folder to cloud of your choice, post back or PM the link ? 
  8. Run Windows in SafeMode with networking, retest the issue, let us know the result ?

Thank you

  1. Windows 10 Pro version 1809 (10.0.17763.195) (but problem exists before that too)
  2. Kaspersky Free 20.0.14.1085 (e)
  3. Yes
  4. WSL version 1, Ubuntu 18.04.3 LTS from Microsoft Store
  5. Yes, I have this problem since the use of Kaspersky
  6. Yes

 

Userlevel 7
Badge +11

Hello  @PDD,

Thank you for replying.

  1. Having checked all requirements, you will have seen WSL/Ubuntu is not supported.
  2. Run Windows in SafeMode with networking, retest the issue, let us know the result ?
  3. Run a GSI & Windows logs, upload the zip folder to cloud of your choice, post back  the link ? 

Thank you

For me, rsync fills up all my 100Mbit network without problems. What speeds are you seeing? Anyway, in application control windows there is a per-application setting “do not scan all traffic” on “Exclusions” tab. Try it. It is not the same as making application trusted.

Reply