Kaspersky
Question

Kaspersky free "error in graphics drivers occurred" 25.09.2019

  • 25 September 2019
  • 7 replies
  • 18797 views

Userlevel 1
Issue at 25.09.2019

After install Kaspersky free (polish), when i want to open it (dubble click on taskbar icon),
It shows loading screen and then window pop-up
"Unexpected error" "Error in graphics drivers occurred". If I tap "ok" then it goes again in the same loop.

i've discovered, when i go to device manager and disable secondary nvidia graphics card, then Kaspersky start and works perfect without any error!
If I then turn back on nvidia card, then Kaspersky works fine as well.
But the issue comeback after restart.
So Kaspersky cannot start IF seconadry card Nvidia is turn on in device manager.

The issue is in Kaspersky free. Intel and nvidia graphics works fine. I've made a lot of test.

Please FIX it. I don't understand for WHAT Kaspesky is "touching" secondary graphics because Intel is primary and works on desktop.


SYSTEM Details:

fresh, clean Windows 10 64bit 10.0.0.18362 install +all updates until 25.09.2019
fresh Kaspersky free 20.0.14.1085 (d)

laptop dell latitude e6420 with optimus graphis:
Primary card Intel hd graphics 3000 (lastest driver 9.17.10.4459)
Secondary dedicated nvidia nvs 4200M (newest drivers pack 392.56 29,07.2019)

(there is NO newest graphics card drivers and windows updates anymore on day 25.09.2019)

7 replies

Userlevel 7
Badge +9
Hi, @oday1 ,
The problem is known. Try this workaround:1. In Registry found key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\
2. In the right half find "AppInit_DLLs" parameter and into it replace the comma with space between parameter values.
- Right click on "AppInit_DLLs" and select "Modify"
- In "Value data" field replace the comma with space:
For example "C:\Windows\SysWOW64\nvinit.dll,C:\windows\SysWOW64\nvinit.dll" change to "C:\Windows\SysWOW64\nvinit.dll C:\windows\SysWOW64\nvinit.dll"
Restart your computer
Userlevel 1
The problem is known. Try this workaround:
1. In Registry found key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows find "AppInit_DLLs" ....


I'm sorry but I don't want to touch Windows's system files or changing system behaviour (in fact there is no "appinit_dlls" key in that path.
But thank you for advice.


I found better (for me) solution.

No matter if you have 32bit or 64bit system just go to:

"C:\Program files (x86)\NVIDIA Corporation\coprocmanager"
and there rename file: nvd3d9wrap.dll to something different. For example nvd3d9wrapX.dll
And that's it. Kaspersky will start witout any error.

You don't even have to restart your computer.
After that I've tested few games (32bit and 64bit) and they work fine on nvidia as well (using gpu-z, I've checked which card was used)

The problem is known. Try this workaround:
1. In Registry found key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows find "AppInit_DLLs" ....

 


I'm sorry but I don't want to touch Windows's system files or changing system behaviour (in fact there is no "appinit_dlls" key in that path.
But thank you for advice.


I found better (for me) solution.

No matter if you have 32bit or 64bit system just go to:

"C:\Program files (x86)\NVIDIA Corporation\coprocmanager"
and there rename file: nvd3d9wrap.dll to something different. For example nvd3d9wrapX.dll
And that's it. Kaspersky will start witout any error.

You don't even have to restart your computer.
After that I've tested few games (32bit and 64bit) and they work fine on nvidia as well (using gpu-z, I've checked which card was used)

 

 

 

Thnaksssssssssssssssssssssssssss Dear

Userlevel 7
Badge +9

Hello  @ikidoMan,

Welcome!

What patch is your Kaspersky software on?

:thinking:

Thank you

Hi all

I had the same problem : "error in graphics drivers occurred" when I wanted to install Kaspersky Antivirus (20.0.14.1085 FR) on my Lenovo G780 (windows 8 French, not 8.1) and I found the solution for me.

I did what oday1 said :

The problem is known. Try this workaround:1. In Registry found key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows find "AppInit_DLLs" .…

***** This solution doesnt work after a reboot *****

 

I did what ikidoman said :

"C:\Program files (x86)\NVIDIA Corporation\coprocmanager"and there rename file: nvd3d9wrap.dll to something different. For example nvd3d9wrapX.dllAnd that's it. Kaspersky will start witout any error.

***** This solution doesnt work after a reboot and no more sound after this reboot , I did a new installation of my Sound Driver it’s ok now  *****

 

I found the solution and kaspersky work fine now ! :

I did an update of my NVIDIA driver (GT635M)  directly on the website www.nvidia.com

 

Bye Bye All

STEF

 

 

 

 

 

"Error in graphics drivers occurred" which appears and keeps coming back preventing KASPERSKY ANTIVIRUS from launching.

This is a known bug in the latest 2020 version of KASPERSKY ANTIVIRUS which does not exist in the 2019 version of the program.

If you have this problem, your PC is equipped with 2 graphics cards.
An INTEL which is a low-power card in electrical energy and which is used when your PC is on battery or in office mode.
The other, more powerfull (Nvidia or other brand) is used for the best video quality, transfer via an HDMI port, ect.
Windows switch from one to the other depending on your setting in Windows Power Options. The INTEL basic graphics card is in perfect harmony with your computer processor and takes up its transfer energy and resources on the processor while also consuming RAM memory.
The secondary card (Nvidia or other brand) is more autonomous, with its own processor and integrated RAM memory. It is however much more greedy in electrical energy.

To temporarily resolve this "error in graphics drivers occurred" problem generated by KASPERSKY, and while waiting for KASPERSKY to resolve its own, you will only use one graphics card on your PC.
To do this, you go to the Windows device manager (peripheric manager) , then go to "Graphics Cards". Right click on the video card you wish to deactivate, then click on "deactivate".
- If you work more on office automation and internet, if you often use your PC on battery, deactivate the most powerful (Nvidia or other brand).
- If you use the battery little, and you rather take photos, video and you use the HDMI transfer, deactivate the INTEL card.
When KASPERKY LAB will have solved its oversight problem in the switch and sharing of video cards, you will be able to reactivate your INTEL or NVIDIA card or another brand.

Otherwise, while waiting for KASPERKY LAB to resolve its dual graphics card monitoring management problem, you can return to the 2019 version of KESPERSKY ANTIVIRUS which works perfectly fine.

A) Uninstall Kaspersky Anti-Virus if the installation has been made

A guide to uninstall applications for Windows 10 is available here: https://support.microsoft.com/fr-tn/help/4028054/windows-10-repair-or-remove-programs

B) Install Kaspersky Anti-Virus 19:

1. Download the installation file for the latest version of Kaspersky Anti-Virus 19.0.0.1088, by clicking on the following link:
https://box.kaspersky.com/f/b8a64633d1944e8da441/?dl=1

The problem is known. Try this workaround:
1. In Registry found key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows find "AppInit_DLLs" ....

 


I'm sorry but I don't want to touch Windows's system files or changing system behaviour (in fact there is no "appinit_dlls" key in that path.
But thank you for advice.


I found better (for me) solution.

No matter if you have 32bit or 64bit system just go to:

"C:\Program files (x86)\NVIDIA Corporation\coprocmanager"
and there rename file: nvd3d9wrap.dll to something different. For example nvd3d9wrapX.dll
And that's it. Kaspersky will start witout any error.

You don't even have to restart your computer.
After that I've tested few games (32bit and 64bit) and they work fine on nvidia as well (using gpu-z, I've checked which card was used)

 

Worked straight away - no reset !

Reply