No Ethernet adapter after Kaspersky Update

  • 16 December 2019
  • 23 replies


System: WIndows 10 Home 64 bit

Kaspersky Free for Windows (latest update today 16.12.2019, but see below)

An hour ago, I got a pop-up message from the Kaspersky application that a restart of the computer is needed (because of an application update apparently).

However, after the restart I can now no longer connect to the Internet via my ADSL broadband connection (only WiFi).

I have already tried:

  • restarting the computer again,
  • restarting the ADSL router/modem,
  • ipconfig /release and ipconfig /renew
  • in Device Manager, scanned for new hardware, but only the two Kaspersky adapters are found.

All without success, but this is not surprising:

ControlPanel/Network Connections  shows that there are now only these two Ethernet adapters left:

  • “Ethernet 2 / Kaspersky Security Data Escort Adapter”
  • “Ethernet 3 / Kaspersky Security Data Escort Adapter #2”

Both show “Network cable unplugged”.

The “normal” (non-Kaspersky) Ethernet adapter has disappeared and thus can no longer be used.

I have so far never used the Kaspersky-specific “Secure Connection”, so I do not really need those two “Data Escort” adapters. There was one installed before this update already, but that did never interfere with the “normal” (non-Kaspersky) Ethernet connection.

Using the Kaspersky Secure Connection to the Internet worked initially, but it broke down after five minutes and could not be re-established.

How can I get the normal Ethernet adapter/ connection back?

Thanks in advance for your help!

23 replies

Userlevel 7
Badge +11

Hello  @alnor,


Please tell us:

:grey_question::one:KAV version & patch

:grey_question::two: Win10 version & build

  • The Kaspersky Security Data Escort Adapter are components of Kaspersky Secure Connection. If you don’t use or do not wish to use KSC-VPN, disable both & or uninstall KSC-VPN. 

It may be the quickest solution is to:

  1. Creat a System Restore Point.
  2. Uninstall KAV.
  3. Shutdown device with Full Shutdown, not Restart.
  4. Restart, login.
  5. Download, install new KAV.
  6. Sync KAV application with MyKaspersky account.
  7. Update KAV Databases.
  8. Run Full Scan.
  9. Recheck? 

Please let us know?

Thank you 

KAV20 Release notes

KAV19 Release notes

KAV18 Releaset notes

Userlevel 7
Badge +11

Additional  @alnor,

A “hint”, I’ve learnt from bitter experience, I create regular (daily/nightly) system restore points, especially around times when I know Windows & or Kaspersky are pushing major updates.

Thank you. 

Hello FLOOD,

many thanks for the quick reply, it’s much appreciated!

Win10 version & build

Windows is still 1803 (Build 17134.829; I know)

KAV version & patch

Thanks for those links! I had so far been unable to find the KAV version from the GUI; there really should be an "About..." item under the Help (”?”)  button.

The UI says the KAV version is (g).
This is also the version seen in the Properties of avp.exe (dated 21.03.2019).
But avp.com is dated 17.11.2019 (and has no version info in Properties).
This may all still be the pre-update version.

However, in the application folder I found a file verinfo.json (dated 09.12.2019) which says
   "build: "KAVKIS-20-MP0-",
   "version": """

This is perhaps the version after the (failed) update?

Create a System Restore Point.

I do have a System Restore Point from a few days ago, but am reluctant to activate it, for fear it may mess up even more things… (As per Murphy’s Law, I am in the middle of some important and urgent work when all this happened...)

Uninstall KAV.

Will uninstalling from the ControlPanel/Programs etc be sufficient, or is there a special uninstaller  I saw one  [LINK REMOVED]  but don't know if this is an "official" and up-to-date one).

I create regular (daily/nightly) system restore points, especially around times when I know Windows & or Kaspersky are pushing major updates.

That is of course good advice. The problem is that I had set Kaspersky AV to automatic updates, and then I do not get any advance warning. I always learn about these updates only when they have already happened, and a restart is requested. I know I can disable automatic updates, but it seems I will then not get any notification either when an update is available.

Thanks again for your help! I’ll report back if/when/how I have solved the issue.

BTW, should there really be two  “Kaspersky Data Escort” Ethernet adapters (see first post), or is that a side effect of the failed update?

Userlevel 7
Badge +9

@alnor The unofficial download link for the KAV Remover has been deleted.

We only suggest this tool in case that problems occurs during a regular uninstall procedure.

Here is the official link but : 

Do not use the kavremover tool unless recommended to do so by Kaspersky Lab technical support engineers”

Thanks, Berny!

Do not use the kavremover tool unless recommended to do so by Kaspersky Lab technical support engineers”

So for users of the free variant (who do not get technical support, as I understand it) it is a no-no in any case, I suppose.

And I’m glad I asked first. :wink:

Userlevel 7
Badge +11

Hello  @alnor

You’re very welcome!

1803, 17134.829. Re the: “I know”, don’t worry, however, do a quick check of  Kaspersky Free 2020, (which btw, from the info you’ve provided, is KAV version installed), just so you’re across the information for your opsys & KAV20. 

Re  “ unable to find the KAV version from the GUI; there really should be an "About..." item under the Help (”?”)  button

Open KAV, select Headset:headphones: , Support window opens, KAV version & patch “should be” 4th line after Kaspersky Technical Support. 

2 other ways to find version & patch:

:one:Windows Taskbar, hover m:mouse: use over Kaspersky icon, floating information  popup will provide Name, version, patch & Database release date.

:two:Windows Taskbar, right click Kaspersky icon, select “About”, window displays Product name, version, patch.

:octagonal_sign: Turning off “Kaspersky Austomatic Updates” will not stop major patch distributions:octagonal_sign:

(imo), the process is flawed, there should be a setting (like Windows) that downloads the patch & allows the Kaspersky Customer the chocie of when to apply, that would at least stop people being caught off guard & give Kaspersky Customers the opportunity to apply the update in a controlled manner. 

  • :radioactive: KAV, BEFORE UNISTALLING:radioactive:
  1. :warning: Check & download new KAV installer:warning: reference: Checking for a newer version of the application.
  2. Log into your MyKaspersky account, check Licenses Tab, KAVF should be listed, check “Details”.
  • Then uninstall KAV via Windows, Programs & Features.
  • The unistall process will present a popup with six selections, save License information only, even if the license information is generic for KAVF:arrow_left:

:no_entry: Do not use Kavremover, unless directed to do so:no_entry:  

  • KSDE x 2, interesting isn’t it:thinking: , I’ve noticed this, atm, have not worked out if it’s another Kaspersky “as per design”, or reflective of failed major updates/patches, still testing. 

Bottom line: if you’re not using KSC-VPN, uninstall it & the adaptors, which you may as well do AFTER you’ve refreshed KAV, otherwise you’ll be doing it twice. 

  • (imo), you don’t need to use the sysrstpoint atm, but, it’s very good you have it:clap_tone3:

I think I’ve covered everything, except for Murphy’s Law, that’s the luck of the Irish, to be sure, to be sure:wink:

Let me know if I’ve missed anything?

Thank you:pray_tone3:

Many thanks again, I appreciate the support!

2 other ways to find version & patch:

Thanks. Following the links you kindly supplied earlier, I had no problem finding that info. My point was merely that it should perhaps be (also) an item under Help/About… which is a more familiar location.

do a quick check

Those requirements are all fulfilled, and KAV was working just fine until last night; in fact it still is (database updates work etc.); the problem is “merely” the missing (in Device Mgr etc) Ethernet adapter…

Update: I have now uninstalled, in the usual manner via the Control Panel, the “Kaspersky Secure Connection” application (but not yet the main application), and restarted as required. No problems encountered. And as expected, those “Data Escort” adapters are now no longer listed in Device Manager, Network Settings, etc.

But this means there is now only WiFi left, no Ethernet adapter is listed at all. Scan for Hardware Changes still did not help; and the usual trick of un/reinstalling (the driver) can’t be used because the adapter (driver) is not listed in Device Mgr in the first place.

I also wonder if un/re-installing the KAV main application would really help: Wouldn’t  that just bring back those “Data Escort” adapters, but not the “normal” one?

  • So, apart from Kaspersky applications, what is the proper method to get back into Device Mgr an adapter which Win10 does not see?
    (The hardware, cable, etc. are still ok, as demonstrated by the VPN connection which shortly did work when I still had “Secure Connection” installed.)

Then there is still the Restore Point, but from what I heard and read, there is a real risk that it will mess WIn10 up even further. At the moment everything still works, at least as long as the WiFi connection is good enough (haven’t yet checked the bandwidth).

Warning about not using KAVremover duly noted! Thanks!

the [auto-update] process is flawed

Indeed. Auto-download and notification are OK, but actual installation should not be happening without prior warning/prompt…

Let me know if I’ve missed anything?

Thanks. I think now that the “Secure Connection” component is gone, it’s a more general issue of how to re-introduce the Ethernet adapter to Win10, once it has lost sight of it… And as said, I’d rather not (yet) try the Restore Point...

Further Update: I remembered (belatedly...) the “Show hidden devices” option of Device MGR and can now see the adapter (Realtek Gaming GbE Family Controller) in the Device Mgr, but with a “greyed out” icon, and Win10 says “Currently, this hardware device is not connected to the computer. (Code 45)”. So I cannot dis/enable it but could only uninstall it. (Which I don’t dare to do as I am not sure how to then re-install it.)
I tried to update the driver, but after checking what is available (on the computer), Win10 then says that the best driver for the device is already installed...

Userlevel 7
Badge +11

Hello  @alnor,

Re: “the hardware, cable, etc. are still ok, as demonstrated by the VPN connection”,  VPN is a virtual device….

Re:  Restore Point, as I said, atm, that’s not being suggested. 

:octagonal_sign: In Control Panel\Network and Internet\Network Connections you cannot see a ethernet controller? Is that correct? 

Please let me know?

Thank you

VPN is a virtual device….

Yes, but it  “pretends” to be an Ethernet adapter, and I think it still has to use the real hardware Ethernet adapter and cable, in order to connect to the VPN server (Ukraine in this case, can’t be changed in the free version). Which it did successfully (for a short time) before I uninstalled “Secure Connection”.  At that time, WiFi was  not yet active, that’s why I think the hardware and cable is ok.

My impression is that the KAV update instead off adding an  “Data Escort” VPN adapter to the “normal” one 8as it was before), it somehow “overwrote” the latter. And unfortunately I cannot figure out how to bring it back.

In Control Panel\Network and Internet\Network Connections you cannot see a ethernet controller? Is that correct? 

Yes, it was indeed correct, until I just now discovered the Device Mgr option to show also hidden devices. Now I can see the adapter but Win10 says it is ”disconnected”.
See the latest update to my post above! (which I wrote in parallel to your message).

In the meantime, thanks for your patience and help!

Userlevel 7
Badge +11

Hello  @alnor 

  1. In your setup, what is Realtek Gaming GbE Family Controller (ethernet) used for? 
  2. Is Realtek Gaming GbE Family Controller (ethernet) visible in KAV?

Please let me know?

Thank you

In your setup, what is Realtek Gaming GbE Family Controller (ethernet) used for? 

It’s the only NIC I have in that computer (was already installed by computer manufacturer), and it connects me to LAN and Internet via an ADSL modem/router. Standard setup, thus. I never configured or changed it in any way (this machine is only a few months old).

Is Realtek Gaming GbE Family Controller (ethernet) visible in KAV?

Hmm, in KAV? I went through all settings (incl. advanced), “More Tools”, and Reports but cannot find any item which refers explicitly to any specific network or adapter.
(Remember this is the free version, so a lot of things are not available. And I have already uninstalled the “Secure Connections” application, if that is what you meant.)

In the Device Mgr, I can now see the Realtek adapter (as “hidden device”), but it is marked as “disconnected” (see post and update above).

Userlevel 7
Badge +11


:octagonal_sign: Right at this moment, how are you connected to the internet? 

And, go to:

Control Panel\All Control Panel Items\Network and Sharing Center, 

Select Change adaptor settings :arrow_right:show an image of the display from :

Control Panel\Network and Internet\Network Connections  :question:

Thank you

Right at this moment, how are you connected to the internet? 

On the same computer we are discussing here (Desktop PC, by the way) , but via a WiFi connection.

This WiFi is the only one currently listed in CP, see image.
(Ignore the “Npcap Loopback Adapter” entry; it is always there but always disabled, and has nothing to do with the problem at hand. I think it comes from a Wireshark installation).

(picture cropped to save space, but these are all entries)

And this is how it currently looks in Device Mgr if “hidden devices” are also displayed.
(I have no idea what Win10 means by a network card being “not connected to the computer”. The PC case has so far never been opened, let alone any changes made with the components inside.)

Device Manager, with “show hidden devices” option activated


Userlevel 7
Badge +11

So before the “problem”, you always connected to the internet using ethernet? 

So before the “problem”, you always connected to the internet using ethernet? 

Yes, correct. On that machine, WiFi was until now always off. The Ethernet adapter has thus always been my only connection to LAN and Internet, via ADSL.

Userlevel 7
Badge +11

:one: Please export KAV All Events Reports, select 30days, save as a .txt file, attach to your reply using the :paperclip: icon ? 

:two: Run a GSI & Windows Logs, upload folder to cloud & post back the link ? 


:three: Run Window Network Troubleshooter, show the result in a screen image please? 

:four: From Device Manager, have you tried enabling Realtek Gaming GbE Family Controller? 

  1. Report is attached.

For context:

I got the KAV message to restart the computer about 16.12.2019 22:00 (local time).

Restart was done at 22:11.

Note that the first problem reported was at 22:41 “Error resolving network name.
At this point WiFi was still not active, and the Ethernet adapter gone, so there was no Internet connection.
(“Error resolving network name.” was not the real issue here; I had already tried to refresh DNS with ipconfig etc, before I noticed that Win10 did no longer detect the adapter at all.)

Later updates (yesterday at 23:02 and more today, 17.12.2019) then succeeded again, because by that time I had WiFi activated as a work-around.

  1. I have first to figure out about GSI & WIndows Log, will do later.
  2. Win10 Troubleshooter is useless. It only checks the WiFi connection, and reports (correctly) that this is working fine.
    I tried to point it specifically to the Ethernet adapter (“use a specific network adapter”), but the list then following again includes only the working WiFi, and the disabled Npcap Loopback adapter, but no Ethernet adapter.
    When I select “all network adapters”, I get “Troubleshooting couldn’t identify the problem.
    View detailed information” then produces info exclusively about the WiFi connection.
    I think the problem here is, again, that Win10 currently does not know that the Ethernet adapter exists at all…

  3. “From Device Manager, have you tried enabling Realtek Gaming GbE Family Controller? “
     The adapter is marked as “disconnected” and I have thus only the Update and Uninstall Device options. I tried Update (with drivers on my computer), and Win10 then told me the optimal driver is already installed.
    (And that driver has so far worked perfectly; so I don’t want to change it for a new one downloaded from the Internet, because that will only introduce further uncertainties.)



Userlevel 7
Badge +11


May I have the KAV 30day All Events report please?

(imo) Windows should be “allowed” to rediscover the network. 

May I have the KAV 30day All Events please?

The file “report_alnor.txt” attached above is that report, or did I miss something?

I selected “More Tools” > “Reports” > “Detailed Reports” > then “30 days” and “All Events”, then exported to TXT file. Not correct?

I am currently also generating a GSI ZIP file, but it seems to take time. I’ll send a link later, when I have uploaded  the file somewhere.



Userlevel 7
Badge +11

The GSI & Windows logs does take time, allow it to run to completion.

The KAV report is from 9/12 to 17/12


Userlevel 7
Badge +11

Hello  @alnor,

Please check: List of applications incompatible with Kaspersky Free.

Thank you. 



the matter has found a very unexpected solution:

Attempting to fix the issue, I had tried (several times) to restart the computer, including “real restarts” (i.e. via “shutdown” on the console/command line, as opposed to merely clicking the item in the Win10 “Power” menu). But it had not helped.

In a last desperate attempt to avoid System Restore and similar major surgery, I tried this again, but this time in addition to the shutdown command also unplugged the power cable, waited a few minutes, then put it back in and restarted the machine. Upon which the Ethernet adapter was visible in Device Mgr etc again, and fully functioning.

(I had not made any further changes to the KAV main application after I had earlier removed (as reported) the “Secure Connections” part.)

So, apparently something originally went wrong with the KAV application update, and that somehow kicked the Ethernet driver out of the configuration; but the following difficulties in getting it back had apparently nothing to do with KAV. (The root problem being that one has to hop through hoops to get Win10 to really really shut down.) In fact, the KAV program as such has worked just fine all the time.

As to the remaining question:

Please check: List of applications incompatible with Kaspersky Free.

From that long list I am using only the Comodo Firewall (also listed as “COMODO Firewall”, but probably the same thing).

However, what I don’ t understand (doesn’t matter for my problem which is now solved; so from mere curiosity):

How can this be incompatible  to KAV?

Note that this only a firewall (not the whole “Suite” etc. -- I know it’s a bad idea to run two AV products side by side), and I have of course given it a rule to let all Kaspersky connections through, both inbound and outbound.
Besides, neither on first installation nor during the application (not just database) updates has KAV ever complained about, or stumbled over, that firewall.
Is there a problem I am missing?

In any case, many thanks again to @FLOOD for the patient and thorough support offered here.
And a happy holiday season to everyone!
Remember: If in doubt, pull the plug. :wink:



Userlevel 7
Badge +11

Hello  @alnor,

Thanks for posting back:pray_tone3:

We’re glad to hear the issue is resolved:ok_hand_tone3: