Kaspersky
Solved

I can't activate my product via two-step verification

  • 31 August 2021
  • 2 replies
  • 47 views

I uninstalled Kaspersky Free to reinstall it because some functions were not working as expected. Now that I installed it, it keeps asking my two-step verification code which was APPARENTLY sent to my phone but I don’t receive it. I’m using Vodafone Turkey as carrier, I switched to it a month ago after using Turk Telekom. With Turk Telekom, I was able to receive two-step verification codes but I can’t with Vodafone, which is pretty weird because Vodafone is the international one, not the local one like Turk Telekom. Is my SIM blocked for security purposes since I switched carriers? Because I couldn’t find any explanation other than this. I tried contacting Kaspersky’s Turkish support, but it doesn’t even let me select my product. I was pretty satisfied with Kaspersky’s products, but it really started to disappoint me.

icon

Best answer by aydogduemremert 31 August 2021, 20:35

View original

This topic has been closed for comments

2 replies

Userlevel 7
Badge +9

@aydogduemremert Welcome.

Please try https://support.kaspersky.com/b2c/  → Select country

@aydogduemremert Welcome.

Please try https://support.kaspersky.com/b2c/  → Select country

Thank you for your response but I found another solution. By using mobile hotspot (which in my case Vodafone’s network) while activating the product, I was able to get a verification code. It’s just weird that when I connected to my home Wi-Fi with activation page open, I didn’t receive any code at all. Should I be on the same IP address with the phone where the two-step verification codes are sent? Also I had tried the site you posted, it was the same page when I used to contact but couldn’t reach the technical support this morning.