Kaspersky
Solved

Protection is disabled. 10.1.2.996

  • 3 July 2019
  • 7 replies
  • 1790 views

Badge
Since upgrading to 10.1.2.996 with network agent 11.0.0.1131 we are getting several servers reporting that "Protection is disabled" When I try to start the protect





I can not seem to turn on the protection or work out why it is disabled. This server is a 2012 R2 as are the other servers where I am seeing the same issue. A GSI is attached. When I look at the Admin server it shows the following

Internal task error occurred. Error code: 0x0007. Subsystem code: 0x6 (WP). For more details go to the Kaspersky Lab Technical Support site: https://click.kaspersky.com/?hl=en-US&link=error&pid=wsee&version=10.1.0.0&error=B6X7X13X20X

The only reference I could find was that to the licence, so I deployed the licence file again which reported that it was successful, but this did not resolve the issue. It also reports that it has an active key
icon

Best answer by Oleg Bykov 3 July 2019, 13:35

Hello,

It seems that the KLAM driver is not registered. 10.1.2 was installed on top of an older KSWS, correct? To correct this, locate klam.inf in the Program Files (x86) folder (our installation folder), right-click on it and select "Install...".
View original

7 replies

Hello,

It seems that the KLAM driver is not registered. 10.1.2 was installed on top of an older KSWS, correct? To correct this, locate klam.inf in the Program Files (x86) folder (our installation folder), right-click on it and select "Install...".
Badge
Thanks for your assistance on this matter. That worked well
To fix this on all affected hosts this command line can be used:

RUNDLL32.EXE SETUPAPI.DLL,InstallHinfSection DefaultInstall 132 C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security for Windows Server\drivers\x64\win8\klam.w8\klam.inf

Hi,

I´m having same issue but when I try to install klam.inf file or run command “RUNDLL32.EXE SETUPAPI.DLL,InstallHinfSection DefaultInstall 132 C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security for Windows Server\drivers\x64\win8\klam.w8\klam.inf”, next error pops up

When I check events from Real Time File Protection module, next one appears

I’m trying to install on Windows Server 2016 Datacenter.

Regards,

Hello,

Does the file “C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security for Windows Server\drivers\x64\win8\klam.w8\klam.inf” exist on your local drive?

Also, will it help if you put the INF file name into quotes? Like this:

RUNDLL32.EXE SETUPAPI.DLL,InstallHinfSection DefaultInstall 132 “C:\Program Files (x86)\Kaspersky Lab\Kaspersky Security for Windows Server\drivers\x64\win8\klam.w8\klam.inf”

 

Hello,

Thank you Oleg for your help. Turns out that this server had another endpoint protection solution installed (Cisco AMP for Endpoints), and it was the cause of this problem. After I uninstalled that product, KS for Windows Server worked fine.

 

Reply / Ответить