Kaspersky
Solved

KSWS 10.1 - Permission warning

  • 22 May 2019
  • 4 replies
  • 168 views

Userlevel 4
Badge +3
Good evening everyone,

today, while browsing through the Kaspersky Security for Windows Server 10.1 policy, I was a little surprised to receive an error message or warning.

When clicking on "Supplementary" -> "User access permissions for application management" I get the message that I am not authorized to display the current KSWS 10.1 permission settings. However, I am allowed to change them.



In the Administration Server settings at "Security" I checked what the permissions look like:


As you can see, KLAdmins and KLOperator Group do exist and their roles are also correct.
Under local users and groups on the Windows server where the Administration Server is installed, I can confirm that my user is in the local administrator group and in the KLAdmin group.

What could be the mistake here?

Best regards
Leon
icon

Best answer by intrusus 11 June 2019, 09:26

The problem with the missing permission is fixed now, I deleted the domain groups "KLAdmin" and "KLOperators" out of the corresponding local groups. I then logged in with my _adm account (member of the local "KLAdmin" group) via the administration console and was able to view and edit the policy. I think we created them some time ago to give our service team access to all KSCs... Sometimes you just forget when you play around with the systems.😥

Question @Nikolay arinchev:
Does the local "KLAdmin" group has to be present in the local "Administrators" group?
This is not the case with our old administration server (KSC 10), so i removed it. Something seems to have gotten messed up here a bit... 😫 In the attachment once again an overview of all local groups.

Thank you & kind regards
Leon✌🏼
View original

4 replies

Userlevel 4
Badge +2
Hi,

Could you please clarify what versions of plugin and KSC do you use?
Userlevel 4
Badge +3
Sure thing,

I am using KSC 11.0.0.1131 and my KSWS plugin is Kaspersky Security 10.1 für Windows Server 10.1.0.622.

Cheers
Leon
Userlevel 4
Badge +2
Could you please confirm that this behavior could be reproduced if you authenticate at KSC with VORDEFINIERT\Arministratoren?
Userlevel 4
Badge +3
The problem with the missing permission is fixed now, I deleted the domain groups "KLAdmin" and "KLOperators" out of the corresponding local groups. I then logged in with my _adm account (member of the local "KLAdmin" group) via the administration console and was able to view and edit the policy. I think we created them some time ago to give our service team access to all KSCs... Sometimes you just forget when you play around with the systems.😥

Question @Nikolay arinchev:
Does the local "KLAdmin" group has to be present in the local "Administrators" group?
This is not the case with our old administration server (KSC 10), so i removed it. Something seems to have gotten messed up here a bit... 😫 In the attachment once again an overview of all local groups.

Thank you & kind regards
Leon✌🏼

Reply / Ответить