Kaspersky
Solved

KES-SP1-Linux: The application administration plug-in is not installed.

  • 22 May 2019
  • 8 replies
  • 152 views

Badge
W

hen trying to add a key to a KES SP1 (10.1.0.5960) for Linux device, I am caught in a loop where KSC10 is asking me continuously to install the application plug-in.

GIF attached.

If I manually uninstall the plugin using msixec and try again, i get the same result.
icon

Best answer by Nikolay arinchev 22 May 2019, 18:43

Hi,

Please remove the plugin as described at the article and reinstall it once again.
Please let us know about result.
View original

8 replies

Userlevel 4
Badge +2
Hi,

Please remove the plugin as described at the article and reinstall it once again.
Please let us know about result.
Badge
I have uninstalled the package using "Msisexec.exe /x packagename.msi". This succeeds without error. I install the package again. Same error as the one mentioned in the first post of this thread.
Userlevel 1
Badge +1
Hi,

Could you please provide full GSI report with event logs from the KSC.

Thank you!
Badge
@Konstantin Antonov a link to the GSI report has been sent via PM.
Badge
Here's a bump.
Badge
This topic was marked with an Answer even though it isn't correct.
Badge
After uninstalling the msi, and reinstalling it, I have the same error.

I logged the msi installation. In the log, there is this line.

code:
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2726. The arguments are: DlgWelcome, ,
MSI (c) (68:20) [11:47:16:262]: Windows Installer reconfigured the product. Product Name: Kaspersky Endpoint Security 10 for Linux. Product Version: 10.0.176.0. Product Language: 1033. Manufacturer: «Kaspersky Lab». Reconfiguration success or error status: 0.
Badge
After running the installer maybe 25 times, it eventually installed. This is not an answer to my initial question but the issue no longer persists.

Reply / Ответить