Kaspersky
Question

Installing Endpoint Security on Linux via Security Center

  • 6 February 2020
  • 5 replies
  • 488 views

Hello,

 

I’m trying to install endpoint security on ubuntu 18.04 lts and it’s not working.

I manually installed the Network Agent and that works fine. Once I try to push the Endpoint Security 11 for Linux we get this error in the logs:


[2020/02/06 11:31:27] +++ Installation kesl version 11.0.0.2706 started
[2020/02/06 11:31:27] +++ Installing from package kesl_11.0.0-2706_amd64.deb
[2020/02/06 11:31:27] Cannot find package file 'kesl_11.0.0-2706_amd64.deb'

How can we fix this?

 

Thanks!


Edit:

And this is the error in Security Center 11:

 

Remote installation has been completed with an error on this device: One of the parameters was invalid. INSTALL LOG: /var/log/kaspersky/klnagent/akinstall-kesl.20200206113127.log
FATAL ERROR: Cannot find package file 'kesl_11.0.0-2706_amd64.deb'
 


5 replies

Hello,

 

I have exactly the same problem :

[2020/02/07 17:35:10] +++ Installation kesl version 11.0.0.2706 started
[2020/02/07 17:35:10] +++ Installing from package kesl_11.0.0-2706_amd64.deb
[2020/02/07 17:35:10] Cannot find package file 'kesl_11.0.0-2706_amd64.deb'
 

 

Same here!

 

Remote installation has been completed with an error on this device: One of the parameters was invalid. INSTALL LOG: /var/log/kaspersky/klnagent/akinstall-kesl.20200309191715.log
FATAL ERROR: Cannot find package file 'kesl_11.0.0-2706_amd64.deb'

Installation was complied after re-creating the package. but on the endpoint there was a error

Error: Job for kesl-supervisor.service failed because the control process
exited with error code.
See "systemctl status kesl-supervisor.service" and "journalctl -xe" for
details.
kesl not started

Userlevel 4
Badge +3

Hi @remkovdhoef 

I think you’ve met all software requirements in advance?

  • Installation of gcc, binutils, glibc, glibc-devel, make, ld, rpcbind
  • Perl interpreter: version 5.10 or higher

Cheers,
Intrusus

The solution was put the kaspersky .deb installer file inside the folder of remote installer.

Reply / Ответить