I can't connect from local to remote Windows on Azure VM via Remote Desktop. - Kaspersky did disabled RDP! [MOVED]

  • 12 February 2020
  • 0 replies


I can't connect to Windows VM on Azure with RDP. (Normally, I connect from my local computer to Azure Virtual Machine via Remote Desktop)
When I installed Kaspersky Endpoint Security 11 in Windows 10 on Azure VM, my RDP connection has failed and "RDP Disabled" setting of Kaspersky Firewall configuration caused this problem.

I took support from Azure Training Course experts and Kaspersky Support Team to cancel "Kaspersky Firewall RDP Disabled setting"
They said: "Run this command on Azure VM: C:\Program Files (x86)\Kaspersky Lab\Kaspersky Endpoint Security for Windows\avp.exe exit /login=yourUID password=yourpassword"
(if you didn't use any password, you can run "avp.exe exit")

I run "avp.exe exit" command via PowerShell on Azure VM console but it didn't work! it returned me with this following error:
“Error: Command is unavailable due to password protection disabled” (Because while I configured the Kaspersky, I didn't set any password.)

Under the circumstances, how can I change "RDP Disabled setting of Kaspersky Firewall configuration" into "RDP Enabled" setting? (with Azure commands)
If it is not possible, can we ignore /override Kaspersky Firewall Configuration to direct RDP connection, via PowerShell or any similar cmdlet?


//Mod Note: moved to the correct section.

0 replies

Be the first to reply! / Ответьте первым!

Reply / Ответить