Kaspersky
Solved

Enable TLS 1.1 and TLS 1.2 on KSC

  • 26 November 2019
  • 4 replies
  • 63 views

  • Community Citizen
  • 2 replies

Hi 

I followed the guide on https://help.kaspersky.com/KSC/11/en-US/174316.htm to enable TLS 1.2 on KSC. Now I’m unable to connect to KSC.

I’m running Windows Server 20212 R2, SQL Server 2012 (11.0.6260)

I have the following error on System Event Log “A fatal error occurred while creating an SSL client credential . The internal error state is 10013.”

I also have the following error on Kaspersky Event Log

“Failed to connect to the database in 600 seconds. #1966 (-2147567259) Cannot connect the DB server”

The SQL server is running without issues. 

 

Any help is highly appreciated as this is becoming as an issue for our compliance standard.

 

Thanks.

icon

Best answer by Nikolay arinchev 1 December 2019, 12:13

Please do the following: 

  1. Make sure that remote SQL Server (or SQL Express) used by the Administration Server is a really 64-bit application (sqlservr.exe is a 64-bit process). At the computer with Administration Server installed do following
  2. install MSOLEDBSQL provider and reboot the computer if required
  3. Set KLDBADO_UseMSOLEDBSQL=1 by defining global environment variable KLDBADO_UseMSOLEDBSQL=1or by setting Administration Server flag KLDBADO_UseMSOLEDBSQL=1 using klscflag.exe (see syntax below). klscflag.exe which is a standard support utility and is included in KSC Typical archive. Download latest version from here.

klscflag.exe syntax: “klscflag.exe -fset -pv klserver -n KLDBADO_UseMSOLEDBSQL -v 1 -t d”

KSC11 supports this soultion out-of-the-box.

 

View original

4 replies

Userlevel 5
Badge +2

Hi,

Could you please clarify what version of KSC do you use?

Thank you!

Hi,

Could you please clarify what version of KSC do you use?

Thank you!

Hi. 

I’m using KSC 11.0.0.1131

 

Thanks,

Userlevel 5
Badge +2

Please do the following: 

  1. Make sure that remote SQL Server (or SQL Express) used by the Administration Server is a really 64-bit application (sqlservr.exe is a 64-bit process). At the computer with Administration Server installed do following
  2. install MSOLEDBSQL provider and reboot the computer if required
  3. Set KLDBADO_UseMSOLEDBSQL=1 by defining global environment variable KLDBADO_UseMSOLEDBSQL=1or by setting Administration Server flag KLDBADO_UseMSOLEDBSQL=1 using klscflag.exe (see syntax below). klscflag.exe which is a standard support utility and is included in KSC Typical archive. Download latest version from here.

klscflag.exe syntax: “klscflag.exe -fset -pv klserver -n KLDBADO_UseMSOLEDBSQL -v 1 -t d”

KSC11 supports this soultion out-of-the-box.

 

Please do the following: 

  1. Make sure that remote SQL Server (or SQL Express) used by the Administration Server is a really 64-bit application (sqlservr.exe is a 64-bit process). At the computer with Administration Server installed do following
  2. install MSOLEDBSQL provider and reboot the computer if required
  3. Set KLDBADO_UseMSOLEDBSQL=1 by defining global environment variable KLDBADO_UseMSOLEDBSQL=1or by setting Administration Server flag KLDBADO_UseMSOLEDBSQL=1 using klscflag.exe (see syntax below). klscflag.exe which is a standard support utility and is included in KSC Typical archive. Download latest version from here.

klscflag.exe syntax: “klscflag.exe -fset -pv klserver -n KLDBADO_UseMSOLEDBSQL -v 1 -t d”

KSC11 supports this soultion out-of-the-box.

 

 

@Nikolay arinchev  Thank you so much. It works perfectly. Appreciate your help

Reply / Ответить