Kaspersky
Question

Device control not working propertly

  • 29 April 2019
  • 3 replies
  • 212 views

We have install in our company kaspersky endpoint 11 as client and security center 11 as well. We implement policies to control USB device access. It work fine for blocking all, but when you add usb device by id it grant access not only to the usb flash memory with that id, also to all the devices with the same model.
After a couple of test we conclude that the id readed for the kaspersky agent is not unique.
Please some inside about this problem and how to solve.

//Moderator Note: Moved to the correct forum.

3 replies

Userlevel 7
Badge +11
Hi,

Have you included the model in the rule other than the id?

Please send screenshots of the devices detected by KES to see if it matches the ids.

Also send screenshots with the step by step of the test performed.

Regards
We test with External Hard Drive ADATA HV620S and if authorize one all others has permitions. This is with other models of device as well.
This is an image of what kaspersky agent identify as ID of the device and the others is the same.

Userlevel 7
Badge +11
Hi,

The truth is that it is something strange that the id that shows is generic ... It should be specific for each device. There is already a patch related to USB devices and the information that KES collects to fill the list of devices, maybe it is related.

Open a ticket in Kaspersky Company Account providing:

  • Detailed description of the problem
  • Getsysteminfo (Gsi) of the host
Getsysteminfo (Gsi) direct download: http://media.kaspersky.com/utilities/ConsumerUtilities/GetSystemInfo6.2.zip
Getsysteminfo instructions: https://support.kaspersky.com/common/diagnostics/3632
  • Screenshot showing the "Generic" id that is displayed.
  • Traces reproducing the problem:
Activate traces https://support.kaspersky.com/14458
Connect hard drive and wait for the Kaspersky message to appear
Stop and collect traces

Regards

Reply