Kaspersky
Question

Cannot Apply License to Mac [moved]

  • 30 October 2019
  • 2 replies
  • 4754 views

We have bought renewal licenses for Kasperky Endpoint Security 10. The licenses were uploaded to the Kaspersky Security Center and I created tasks to apply them to Windows devices and a different task to apply them to Macs. But though the license successfully applied to the Windows machines, it did not do so with the Macs. Interestingly there was no error per se. It just said the devices had been “Modified”. But checking from the client machines, the license was not applied. Some of the devices were inaccessible because they were not in the office, that is clear. But three others were in the office but only get the status of Modified without the license being applied. What could I be doing wrong. I would appreciate some help.

 

 


2 replies

Userlevel 3
Badge +2

We have bought renewal licenses for Kasperky Endpoint Security 10. The licenses were uploaded to the Kaspersky Security Center and I created tasks to apply them to Windows devices and a different task to apply them to Macs. But though the license successfully applied to the Windows machines, it did not do so with the Macs. Interestingly there was no error per se. It just said the devices had been “Modified”. But checking from the client machines, the license was not applied. Some of the devices were inaccessible because they were not in the office, that is clear. But three others were in the office but only get the status of Modified without the license being applied. What could I be doing wrong. I would appreciate some help.
 

Hello!

What would be the result if you try to create a task for one accessible host and run it?

Thank you!

Hello Dmitry,

Thank you for your assistance. I called our technical support unit and they came to help me. It turned out that the Network Agent on all the Mac devices was missing. So they had no access to the KSC. After reinstalling the agent on the Macs, the license was successfully pushed. 

It appears I was misled by the status of “Modified” which made me think the KSC was communicating with the clients when that was not the case.

What I do not understand is how the Network Agent got missing. It is something I have noticed with both Windows and Apple hosts that after a while, the agent tends to disappear. Our support person insists that it is our users who uninstall the agent themselves but I find that very hard to believe.

Reply