Kaspersky
Question

printer blocked by kaspersky antivirus


  • Once posted
  • 1 reply
Hi,

I'm using windows 10 Home x64 Build 17134 and I installed kaspersky antivirus version 19.0.0.1088(e). My printer is a Canon MG5650 connected to my laptop via wifi.

When the antivirus is active I can't print because windows says that the printer is offline. However, when I shutdown the antivirus I can print as usual. I suspect I have to modify a parameter in the antivirus but I don't know which one and how to modify it.

Thanks for your help,

Carlos

11 replies

Userlevel 5
Badge +1
H @cep and welcome to the new Kaspersky Forum Community.
Maybe in your printer "settings" are incorrect as set as "offline"
Please take a look in the URL below, as it as been an issue.
https://support.microsoft.com/en-us/help/4027988/windows-10-change-a-printers-status-from-offline-to-online
Thank you.
Userlevel 6
Badge +3
Hello Carlos,
As well as the info from Kardip, please check as per the following image:
Windows, Settings, Devices, Printers & Scanners: click: Canon MG5650, select: Open Print Queue:


If [Use Printer Offline] is greyed out. please:
  • Turn off Canon MG5650
> leave off
  • Disconnect wifi connection
> leave disconnected
  • Select [Open as Administrator]
> Check if [Use Printer Offline] is greyed out - Yes?
  • Select [Open as Administrator]
>UAC, change print settings popup will activate, answer [yes]
  • Reboot Laptop
  • Restart/connect wifi
  • Restart Printer - please ensure the [Ready] button is ON/Green - on the Canon MG5650
  • Recheck [Use Printer Offline] status
Still offline
[No]?
[Yes]?
If the Windows status still shows "printer is offline", where exactly is this information showing please?

Please let us know?
Thanks.
Userlevel 5
Badge +3
Change the network name if necessary, and select the network type in the drop-down list:
  • Trusted network: recommended only for networks that are secure against attacks and attempts to get unauthorized access to data on the computer.
https://support.kaspersky.com/14314#block1
Hi @KarDip @FLOOD & @kmscom,

Thank you for your help. I followed your instructions and nothing has changed. I checked and the printer isn't offline. In fact, the printer is not responding when I send a document to print. I got the following message:



@kmscom I have kasper-sky anti-virus and I don't have the firewall option in the the anti-virus :(


I suspect that a configuration feature is blocking the communication between the PC and the printer but I don't know which one 😞

what else could I try? I need your help,

Carlos
Userlevel 6
Badge +3
Hello Carlos,
Thanks for posting back and the additional information.
  • Re KAV [Firewall] option:
*** Are you free or paid KAV please?

When Canon MG5650 was first setup, was it via Windows, automatically discovering the printer?
Or was Canon MG5650 added manually?

Windows product?,
Version ?,
OS build?

Please let us know?
Thanks!
Userlevel 6
Badge +3
Hi Carlos,

after you've gotten some tips, one of mine, too:
KAV examines encrypted connections. Somewhere you can disable this in KAV (for testing purposes). With KIS you find the option under 'Settings->Additional->Network'. Choose the option 'Do not scan encrypted connections' and then check how the printer behaves.
Userlevel 5
Badge +1
Hi @cep
Thanks for the update.
Also above posts.
Maybe take a look at instructions from "howtofixprinter" help section concerning" Cannon printer not resonding"
Take a look bottom URL
http://howtofixmyprinter.com/printer-issues/how-to-fix-canon-printer-not-responding-error/
Thank you.
Userlevel 6
Badge +3
Hello Carlos,
Apologies, I missed your Windows product/version info.
Premium/Free KAV: [Comment configurer les paramètres des connexions chiffrées][How to configure encrypted connections settings] https://help.kaspersky.com/KAV/2019/fr-FR/157530.htm.
If "Do not scan encrypted connections" test works, we can add an exclusion for the printer.
Also:
  • Turn printer OFF - leave off.
  • In Windows, Settings, Printers & Scanners, please check: Let Windows manage my default printer. If it's [▪️] selected, please deselect.
  • Shutdown power off PC.
  • Power off Wifi.
**Restart Printer - make sure it shows a green/ready.
**Restart Wifi.
**Restart PC.
Check for the errors -:
"Print data cannot be sent bc of the current printer status"
"Printer is not responding"
If those errors have gone please:
  • Select: Scan encrypted connections" again.
  • Reboot PC.
Check for original "Offline" error...
> resolved ?
If not resolved, there's more to do..
Please let us know how you go so we can continue?
Thanks.
Userlevel 6
Badge +3
Also, for users with KIS/KTS (=> Kaspersky FireWall):

1.- Check NetWork connection in Windows is setup as Private.
2.- In Kaspesky FireWall be sure Your network is setup to Trusted.
3.- Try also this tweak in Kaspersky FireWall (allowing TCP/UDP Local services):

I was facing the same issue after installing kaspersky .....

---------
Moderation Edit : PUB removed and Member banned
Userlevel 6
Badge +3
X-posted "Spamvertizing" question. Mod actioned post, answer not required.

Reply / Ответить