Kaspersky
Solved

Confirmation Required popup for Kaspersky settings change won't respond when using RealVNC remotely [Solved][Closed]

  • 4 August 2019
  • 8 replies
  • 8243 views

Kaspersky AV 19.0.0.1088(f), Windows 10 Pro 64-bit,
Real VNC®️ Server 5.3.2 (r19179) x64

Accessing my PC remotely using RealVNC, I made a change to AV settings and got the confirmation required popup and was annoyed to find that I couldn't click the "Continue" button from the remote client.

Fortunately, I was just upstairs in the den, so coming down to use the keyboard and mouse wasn't the end of the world.
icon

Best answer by kmscom 4 August 2019, 20:22

Real VNC add to the list of trusted applications https://support.kaspersky.com/14866#block3 and enable exception Allow interaction with the Kaspersky Anti-Virus interface
View original

This topic has been closed for comments / Тема закрыта для комментариев

8 replies

Userlevel 7
Badge +8
coming down to use the keyboard and mouse wasn't the end of the world.

Hello @Bert,
Welcome!
Thank you for providing specific info & screen image👌🏽
It's good to hear the 🌐 hasn't ended😉.
May we know:
  • Opsys version? & build ?
  • KIS - free or licensed?
  • Have you checked the RealVNC settings/permissions?
  • Does RealVNC have a "trusted" app status in KIS?
  • Are there any events logged in KIS REPORTS for RealVNC? If "yes" can you export the report & upload it using the "upload icon" please?
  • Have you tried adding an exclusion for RealVNC?
Please let us know?
Thanks
Userlevel 7
Badge +6
Real VNC add to the list of trusted applications https://support.kaspersky.com/14866#block3 and enable exception Allow interaction with the Kaspersky Anti-Virus interface
Adding one of the executable components of VNC Server was all that was needed to fix my problem, specifically

\Program Files\RealVNC\VNC Server\vncagent.exe

Thanks to FLOOD and kmscom.

[By the way, a long time ago I encountered a problem on the forum where the "Reply" button wasn't present in a message I wanted to send. Even though I managed to finally get the message sent, I never knew how I'd fixed it. I know now.
Using "Firefox" browser, if the window is not maximized, the "Reply" button is not present in a reply message. Maximizing the screen makes the button appear. Don't know if I'm alone in this problem, or how to report it to the Web server maintenance people, but there it is 🙂]
Userlevel 7
Badge +8
Adding one of the executable components of VNC Server was all that was needed to fix
Thanks to FLOOD and kmscom.
[By the way, a long time ago I encountered a problem on the forum where the "Reply" button wasn't present in a message I wanted to send. Even though I managed to finally get the message sent, I never knew how I'd fixed it. I know now.Using "Firefox" browser, if the window is not maximized, the "Reply" button is not present in a reply message. Maximizing the screen makes the button appear. Don't know if I'm alone in this problem, or how to report it to the Web server maintenance people, but there it is 🙂]

Hello Bert,
Thank you for letting us know🙏🏽, we're delighted the issue is fixed.
The "hidden" reply button, has been raiised by a few folks, your solution is a valuable contribution. Thank you for that also. Others have found, increasing or decreasing the "page zoom" also "unhides" the reply button.
Thanks again & best regards.

The problem with these answers is that there is no possible way to configure Kaspersky remotely since there’s no possible way to add your VNC program to the list of the problem (since you cannot confirm via any VNC client) - at least not remotely.  For IT people, this is a nightmare forcing you to go to each and every PC on a network just to do something this simple.
My advice: don’t make blocking remote desktop the default setting!  Read the current firewall settings in Windows and use those exclusions by default (like ESET and most other business-grade antivirus programs do!).   Now I have to drive for 2 hours to fix this.
 

Userlevel 7
Badge +8

Hello  @carpetman,

Welcome!

Are you using Kaspersky Anti_Virus from Kaspersky’s Home Software range and you also wish to manage the “remote” networked devices? 

Please let us know?

Thank you. 

I just came across the same issue. However, I am 3,000 miles away. And, the computer in which I need access to to make changes to the Kaspersky settings is run by a 86 year old woman. So I would need to find someone local to her to add my remote app to the allowed list. This sucks.

Userlevel 7
Badge +8

Hello @JustMeK,

Welcome!

Are you able to step the remote user through enabled inbuilt Windows Remote Desktop, just for you to access the device?

If access can be established you’d be able to install & configure the software you wish to use:thinking: 

Please let me know?

Thank you:pray_tone3:

Flood:whale: