Kaspersky
Solved

Problem mit Windows Updates und KSC 13

  • 2 August 2021
  • 8 replies
  • 176 views

Hallo zusammen,

 

vor kurzem habe ich das KSC von Version 12.2 auf 13 aktualisiert (Clients nutzen KES 11.6).

 

Seit dem gibt es allerdings ein kleines Problem bei der Verteilung von Erforderlichen Updates:

  • Die Clients werden nicht zu einem Neustart aufgefordert
  • Im KSC wird in der Aufgabe als Status entweder
    • “x Updates (...) werden installiert” oder
    • “Suche nach erforderlichen Updates” angezeigt
  • dieser Status ändert sich auch über mehrere Tage nicht mehr
  • Startet man den Client manuell neu werden die Updates installiert und der Status im KSC wechselt auf abgeschlossen
    • Hier hilft wirklich nur ein Neustart - Herunterfahren und neu Hochfahren hilft nicht
    • Auf Neustart bzw. Herunterfahren warten ist allerdings nicht aktiviert (und ändert auch nichts an dem Problem wenn aktiviert)

Hat eventuell jemand eine Idee wo hier das Problem liegen könnte? Könnte eine Reinstallation von KSC helfen? Bleiben alle Einstellungen etc. dabei erhalten?

 

Danke und viele Grüße

Alex

icon

Best answer by alkapwn 10 August 2021, 12:08

View original

8 replies

Userlevel 6
Badge +5

Hallo Alex,

wie ist denn das Patchmanagement konfiguriert? Arbeitest du WSUS-integriert oder fungiert der Admin-Server als WSUS?
Gab es dies bzgl. Änderungen in der Konfiguration?
Schau bitte auch mal nach deiner Datenbankgröße. Ist hier vielleicht irgendein Limit erreicht? Größe der DB oder Anzahl der Einträge?

Grüße
Alex

Hallo Alex,

wie ist denn das Patchmanagement konfiguriert? Arbeitest du WSUS-integriert oder fungiert der Admin-Server als WSUS?
Gab es dies bzgl. Änderungen in der Konfiguration?
Schau bitte auch mal nach deiner Datenbankgröße. Ist hier vielleicht irgendein Limit erreicht? Größe der DB oder Anzahl der Einträge?

Grüße
Alex


Hallo Alex,

 

vielen Dank für die Antwort.

Der KSC-Server selbst dient als WSUS - die Datenbankgröße und Einträge habe ich geprüft und bei diesen ist noch kein Limit erreicht.

Einstellungen wurden nach dem Update keine geändert - was ich jetzt noch prüfen werde ist, ob die Neuanlage einer Aufgabe das Problem behebt.

Aktuell sind die Einstellungen wie folgt:

  • Start: manuell
  • Installiert werden alle genehmigten Updates
  • Der Benutzer wird alle 120 Minuten zum Neustart aufgefordert (eben diese Aufforderungen erfolgt nicht - obwohl die Updates installiert wurden)

Nachrichten an den Client senden funktioniert soweit - diese werden entsprechend angezeigt.

Grüße

Alex

Userlevel 6
Badge +5

Die Aufgabe zu prüfen ist eine gute Idee. 

Hier konnte ich schon beobachten, dass durch die Umstellung der WSUS-Konfiguration die Updates nicht mehr korrekt angewendet werden. 

Prüfen kannst du das in den Aufgaben “Installation erforderlicher Updates und Schließen von Schwachstellen”:

 

Unter “Zu installierende Updates” müssen alle Updates angezeigt werden, die genehmigt sind (in deinem Fall) und auf einem Gerät fehlen, für das diese Aufgabe greift.

Falls die Liste wieder Erwarten leer ist müsstest du die Regel für die Update-Installation neu erstellen.



Grüße
Alex

Hi,

hat nun leider etwas gedauert, weil ich auf neue Updates gewartet habe.

Die Neuanlage einer Aufgabe behebt das Problem nicht. In der Liste der zu installierenden Updates sind welche enthalten. Habe auch viele verschiedene Einstellungen in der Aufgabe getestet, ohne Erfolg.

Habe auch den Administrationsserver neu gestartet um evtl. hängende Prozesse zu beenden - ohne Erfolg.

Vorher war es ja so, dass wenn Updates abgeschlossen wurden, wurden die Geräte auf denen ein Neustart nötig ist in einer separaten Übersicht angezeigt. Aktuell bleibt der Status ja auf “x Updates werden installiert”. Nach einem manuellen Neustart nach einiger Zeit sind die Updates dann trotzdem installiert.

Kann man das KSC denn irgendwie zurücksetzen ohne die Verbindung zu allen Geräten zu verlieren? Evtl. hängt ja wirklich irgendwo eine Einstellungen oder eine Aufgabe fest.

Grüße

Alex

 

Userlevel 6
Badge +5

Auf welchem Patch-Level sind deine Installationen?

Für Server und Netzwerkagent v13 sollte Patch openssl installiert sein. Der Patch für die Netzwerkagenten wird in der Regel automatisch verteilt, den Patch für den Server findest du unter …

Die EXE vorher wegkopieren und in einem anderen Ordner ausführen, da hier Dateien und Ordner extrahiert werden. Das erleichtert das Aufräumen nach der Installation.

Für KES11.6 ist PF8913 der aktuellste mir bekannt kumulative Patch. Den PrivateFix musst du beim Support anfordern.

Grüße
Alex

Hi,

also KSC ist auf 13.0.0.11247 und KES auf 11.6.0.394

 

Hab soeben gesehen für KSC ist Version 13.1.0.8324 vorhanden - werde mal versuchen ob sich die Probleme dadurch beheben.

Gruß

Alex

Userlevel 6
Badge +5

Danke für den Hinweis auf KSC13.1


Allerdings meinte ich das Patchlevel. Falls das KSC-Upgrade nichts bringt wäre PF8913 für KES11.6 einen Versuch wert.

Grüße
Alex

Ok, also das KSC-Upgrade hat nun den Fehler behoben. Sofort danach wurden die Clients zum Neustart aufgefordert wie es sein sollte und der Fortschritt in der Aufgabe wird wieder richtig angezeigt und auch abgeschlossen.

 

Das Problem ist somit behoben!

 

Danke und Gruß

Alex

Reply