Kaspersky
Question

Eine neue Version des Administrationsagenten wurde gefunden


Badge

Hallo zusammen,

 

leider haben wir seit einiger Zeit das Problem, dass wenn ich auf einem Client den Kaspersky neu installieren möchte, ich die folgende Fehlermeldung erhalte:

 

 

Jetzt meine Frage: Wie kann ich denn bitte den Administrationsagenten in meinem KSC aktualisieren?

Ich habe derzeitig:

 

Liebe Grüße

Antrox


6 replies

Userlevel 6
Badge +5

Hallo Antrox,

das der Agent auf den Clients eine höhere Versionsnummer als das Paket im KSC aufweist liegt in der Regel an den Auto-Updates.
Für Version 13.0 gibt es hier aktuell Patch A und den OpenSSL-Patch.

Je nach Einstellung in der Richtlinie werden diese Updates automatisch installiert:
 


Eine Aktualisierung des Paketes im KSC ist nicht erforderlich, da die Updates mit dieser Einstellung auch bei der Erstbetankung gleich mit installiert werden.

Grüße
Alex
 

Badge

Hallo Alex,

vielen Dank für deine Antwort - Diese Einstellung habe ich auch so gesetzt -

Sowohl im Installationspaket:

als auch in der Agenten Richtlinie:

 

trotzdem erhalte ich die Fehlermeldung wenn ich den Agent neu installieren möchte…

 

Liebe Grüße

Antrox

Userlevel 6
Badge +5

Klar, die Fehlermeldung kommt, da offensichtlich bereits ein aktueller gepatchter Agent auf dem Zielsystem vorhanden ist.

Stellt sich die Frage: Warum willst du denn den Agent erneut ausrollen, wenn er doch schon drauf und aktuell ist?

Grüße
Alex

Badge

Naja also generell sollte es doch möglich sein, den Agenten neu zu installieren - unabhängig vom Grund…?

Userlevel 6
Badge +5

Was du mal testen könntest: Nimm in der Installationsaufgabe den Haken bei “Anwendung nicht neu installieren, wenn sie schon installiert ist” raus.
 

 

Sonst hilft vermutlich nur deinstallieren und anschließend neu installieren.

Grüße
​​​​​​​Alex

Userlevel 3
Badge +1

ich hatte das auch einmal.

Man kann div. Agent Patches (z.B. a) im Installationsordner (KLSHARE\Packages\NetAgent...\exec) in den Unter- Ordner Patch kopieren (falls er nicht existiert, einfach erstellen), wonach das dann auch gleich mitinstalliert wird. Dann war das Problem bei mir erledigt (etwaige autonome Installationspakette löschen und neu erstellen, sofern der Agent dabei mitinstalliert wird).

Reply