Kaspersky
Question

Sicherer Zahlungsverkehr bockt /hängt [verschoben]

  • 22 July 2021
  • 6 replies
  • 121 views

Userlevel 3
Badge

Windows 10 (V 20H02 (Build 19042.1110))  Firefox 9.0 64 bit, KIS 21.3.10.391:

Verschiedene Geräte (Desktop, Notebook) laufen bei Zahlungen (sicherer Zahlungsverkehr) nicht mehr durch.

Eigentlich bin ich ein sehr zufriedener KIS User und habe keinen Probleme bis auf das ungewöhnliche Verhalten der Windows 10 Geräte in den letzten Tagen.

Liegt es am Firefox update? Am Windows Patch day? An uBlock? Am Oracle Java Script? Oder am PayPal - Bank-Konto handshake?

Ablauf wie folgt:

  • Aufruf einer Internet Zahlungsseite  und Warenkorb zur Zahlung
  • Start des Zahlungsverkehrs wie gewünscht mit einer Sicheren Browser Seite. Alles OK
  • Eingabe Creditkarte Nummer etc. OK
  • Abfrage und Eingabe der PIN OK
  • Neue Seite mit Abfrage und Eingabe TAN (kommt per SMS auf mobile)
  • Eingabe TAN….was meistens gar nicht mehr geht da Fenster bereits eingefrohren ist … und…dann...falls es nocht geht..
  • ENDE… Bestellung wird ohne Fehlermeldung nicht weiter durchgeführt.

Alles hängt. Es geht nicht weiter trotz Eingabe TAN. Zahlung ist (nach Rückfrage) nicht erfolgt. Bestellung ist nicht erfolgt.

Sobald ich KIS und den sicheren KIS Zahlungsverkehr stoppe, den Bestellprozess neu starte (ohne sicherem Zahlungsverkehr), läuft alles problemlos durch. Kartennummer, PIN, TAN, usw. und dann …Bestellung abgeschlossen!

Das abschalten uBlock in FF ändert nichts am Problem. Woran liegt es also???

Dies ist an mehreren Geräten (Notebook, Desktop) und Bestellungen (verschiedene Internet Firmen/Bank accounts/Kreditkarten) jederzeit reproduzierbar?

Woran kann es liegen?? Habe ich was falsch eingestellt? Gibt es Kollisionen zwischen irgendwelchen Tools?

 

Fragen über Fragen….


6 replies

Userlevel 3

Ich glaube nicht, dass Du irgendetwas falsch gemacht hast, da ich ähnliche Erfahrungen gemacht habe. Aus diesem Grund habe ich, zumindest vorerst, den “Sicheren Zahlungsverkehr” deaktiviert.

 

Userlevel 6
Badge +1

@Wallaby53

Deine Schilderungen: 

Ablauf wie folgt:

  • Aufruf einer Internet Zahlungsseite  und Warenkorb zur Zahlung
  • Start des Zahlungsverkehrs wie gewünscht mit einer Sicheren Browser Seite. Alles OK

Die Internet  Zahlungsseite und Warenkorb zur Zahlung ist auch im sicheren Zahlungsverkehr gestartet ? 

 

Teste mal wenn Du beide Seiten aktiv im sicheren Zahlungsverkehr hast. Zum Beispiel meldest Du dich zuerst in PayPal an über den sicheren Zahlungsverkehr.

Dann die Internet Zahlung im sicheren Zahlungsverkehr  über den Warenkorb. 

 

Wenn beide Seiten im sicheren Zahlungsverkehr drin sind sollte es funktionieren. 

Die Einstellungen im FF sind die gleichen wie hier bei mir ? 

 

 

Userlevel 3
Badge

Nur der der Vollständigkeit halber. Ich habe seit langem KL Produkte im Einsatz und der Sichere Zahlungsverkehr Prozess hat vom  Start bis zum Abschluss gut funktioniert.  Obwohl ich aus dem IT Support komme wusste ich nicht weiter .. ergo…diese Anfrage. Ich befürchte dass ich das Problem nicht gut beschrieben habe oder dass es nicht erfasst wurde denn die Antwort passt nicht zum Thema. Also noch ein Versuch.

Erst seit ca. 4-5 Wochen habe ich diesen Fehler. Zuerst habe ich es ignoriert (ist wohl instabiles Netzwerk oder VDSL) dann hat es genervt (immer bei der Bank anrufen ob die Bestellung durch ist) und jetzt habe ich es abgeschaltet (will ja nicht mehrfach das Gleiche bestellen).

@Longlife “Die Internet  Zahlungsseite und Warenkorb zur Zahlung ist auch im sicheren Zahlungsverkehr gestartet ? “

Der Sichere Zahlungsverkehr startet IMMER erst NACH der Fertigstellung des Warenkorbs nachdem das Feld “zur Kasse“ oder „Bestellung abschließen“ angeklickt wurde. Die folgenden screens rufen sich dann IMMER im secure browser gegenseitig und nacheinander auf -works as designed. Ich hatte zwar im post schon alles beschrieben aber hier nochmal der step-by-step Ablauf

  • Mein Warenkorb ist fertig und (je nach APP) kommt dann “…Zahlen“.
  • Dann erscheint das Formular mit den Datenfeldern wie Karten#, Ablaufdatum, CVV usw.
  • dies führt (automatisch) zum Formular Eingabe Banken PIN (nach Bank unterschiedlich)…
  • die Eingabe der Banken PIN schickt einen TAN per SMS und (immer noch im secure browser)
  • startet ein Fenster in dem ich die TAN eingeben soll/kann

Hier fängt das Problem an. Entweder ich kann die TAN noch eingeben aber nach „Weiter“ hängt der Bestellprozess…. oder ich kann in dem Feld nicht mal mehr die TAN eingeben da es bereits jetzt hängt. Hier kann ich nur abbrechen (egal ob 5-15 Min) und die Bestellung ist nicht abgeschlossen.

​“@Longlife “Teste mal wenn Du beide Seiten aktiv im sicheren Zahlungsverkehr hast“  
Es gibt nicht „beide Seiten“ die Formulare/Pages werden sequentiell nach der Eingabe der Felder durch „weiter“ aufgerufen. Immer noch im secure browser.

@Longlife “  Zum Beispiel meldest Du dich zuerst in PayPal an über den sicheren Zahlungsverkehr“.
Ich hatte und habe kein PayPal daran hat sich im Laufe der Zeit nichts geändert. Weder im FF setup noch in den KIS proxy settings.

Hinzu kommt dass das Problem auf mehreren Geräten auftritt. Also noch mal die

Frage: Woran kann es liegen dass der Sichere Zahlungsverkehr nicht mehr durchläuft??

Kann es Java, Fritz-Box updates, Windows oder Kaspersky sein die dieses Problem jetzt verursachen? An den Einstellungen der Geräte wurde außer regelmäßigen SW Updates nichts geändert.

@Buddel und Kaspersky: Dies kann nicht die Lösung sein. Muss ich jetzt eine weiter Komponente des Produktpaketes KIS für immer abschalten?

 

Userlevel 3

@Buddelund Kaspersky: Dies kann nicht die Lösung sein. Muss ich jetzt eine weiter Komponente des Produktpaketes KIS für immer abschalten?

 

Da stimme ich Dir voll und ganz zu, jedoch habe ich die Komponente “Sicherer Zahlungsverkehr” abschalten müssen, da sie häufig nicht so funktioniert, wie es sein soll. Ich habe derzeit nicht vor, diese Komponente wieder zu aktivieren.

Userlevel 6
Badge +1

@Wallaby53 

Ich kann Dir nur meine Erfahrungen mit Kaspersky Produkten wiedergegeben. 

Beide Seiten  wie die Kauf/Bestellseite und die Zahlung Seite sollten im sicheren Zahlungsverkehr gleichzeitig aktiv sein. 

Bei Dir startet er ja erst nach der Fertigstellung des Warenkorbes(Dass würde für mich heissen, deine Kaufseite mit dem Warenkorb ist gar nicht im sicheren Zahlungsverkehr von Anfang an und der isolierte Vorgang beginnt nun erst. ) 

 

Wie Du aber beschreibst, hat dass vor circa4 bis 5 Wochen ohne Einschränkungen funktioniert.

Dann gehe ich davon aus, dass meine Ansichten und Verständnis vom sicheren Zahlungsverkehr veraltet sind, den ich ging immer davon aus, dass alles in einer isolierten Umgebung ablaufen soll von Anfang an und nicht nachträglich. 

 

 

Userlevel 3
Badge

Ich habe derzeit keinen Bedarf für eine Bestellung kann also nicht testen ob es anders ist wenn ich jede Seite wie Warenkorb und Zahlung einzeln aufnehme. Kann es probieren sobald ich was brauche aber…

  1. hat es funktioniert und keine der vorhanden URL`s wurde in meiner Liste entfernt/modifiziert
  2. ich wollte nicht schon beim Warenkorb in den secure browser denn da geht kein print-screen was manchmal nützlich ist
  3. bis jetzt war auch immer nur die Seite mit dem Zahlung start bei mir in der Liste und die läuft theoretisch
  4. wenn der Zahlungsverkehr gar nicht starten würde dann wäre die URL falsch aber er startet …und hängt erst später

Es wäre ja auch ein pain in the neck wenn ich alle diese Seiten einzeln einpflegen muss (Warenkorb, Zahlungsseite usw.) Hinzu kommt dass außer meiner Liste in Sichern Zahlungsverkehr KL schon eine Liste von Bank/Zahlungsseiten hat die automatisch den Zahlungsverkehr starten ohne dass ich sie in meine Liste eintragen muss.

Bei der nächsten Bestellung werde ich

  • vorab URL aus meiner Liste entfernen.
  • dann den Kaufprozess durch KL Secure payment starten
  • dann sollte auch das Fenster mit secure payment starten wo auch immer der Prozess es für nötig sieh und durchlaufen.

Eventuell wird beim Warenkorb Script ein Parametern gesetzt der dann am Ende des Scrips fehlt…

Irgendwer hat irgenwo was geändert. Ich definitiv nicht und schon gar nicht auf mehreren Geräten gleichzeitig. Die Änderungen können bei KL im letzten patch stattgefunden haben (security) oder sind eine Folge der Sicheheitsumstellungen bei den Banken…die in den letzten Monaten überall stattgefunden haben.

Es gibt Dinge zwischen Himmel und EDV die glaubt man nicht…

Keep you posted.

Reply