Kaspersky
Question

[mobile] No In App Link protection - chrome is set as standard [moved]

  • 21 October 2019
  • 43 replies
  • 2077 views

Hi,

i can’t turn on the in-app link protection because Kaspersky always tells me that chrome isn’t  the standard-browser. But chrome is the standard browser. 

I tried to uninstall and reinstall Kaspersky, i tried to reset the standard- apps and set them again. Nothing helped.

Running it on a OnePlus 3, OS and apps are always updated.

 

Anyone who knows this problem or can help me with that?

 

Thanks!


43 replies

Dear Support,

 

I have this same issue on my Android smartphone Huawei Nova 5T. I already selected Chrome as default browser (several times), cleaned cache and restarted the device many times. Important to say that Accessibility is activated to KIS. But, unfortunately, in the end, the problem remains: KIS issue notification persists and “Check in-app links in Chrome” option unable to activate.

 

Follow the information about the device, system and app:

 

Device: Huawei Nova 5T

Android version: 10.0.0.200

Kaspersky Internet Security Premium: 11.46.4.3115

Chrome: 83.0.4103.83

 

Please I need help to fix that because I'm worried about the protection of my smartphone and Internet browsing.

 

Thank you all. Best regards.

Userlevel 7
Badge +9

 Hello @marcosgdias

Welcome!

  • Please contact Kaspersky Technical Support, they will request an AIDA64 report, a video, images and a detailed history of the issue. Also, the support team may need traces, if so, they will ask you to install a special KIS version. 
  • After you submit the request, you’ll receive an automated email with an INC+12 digits reference #, then, normally, within 5 business days, a Kaspersky Lab human will contact you, also by email, you may continue to communicate with them via reply email & or by updating the INC in your MyKaspersky.com account.

Please let us know what they say?

Thank you:pray_tone3:

Flood:whale:

Kaspersky Internet Security for Android

Hello FLOOD,

 

Ok, understood. I already submitted the request (INC000011589973). By the way, this is the second request about the same issue. After the first one, the Support Team replied saying that an update during May would be released to fix this, but unfortunately didn’t happened.

 

Yes, for sure. Thank you.

Userlevel 7
Badge +9

Hello @marcosgdias,

Thank you for the additional information:ok_hand_tone3:

Please be sure to advise the Technical Team the original INC reference number and that the issue remains unresolved.

Please let us know what they say?

Thank you:pray_tone3:

Flood:whale:

the same issue remains even after upgrading to Android 10 with Oxygen Os 10 on my oneplus 5t

Userlevel 7
Badge +9

 Hello @sigmazero

Welcome back!

  • Have you raised a case with the Technical Support team?
  • If “no”, please contact Kaspersky Technical Support, ​​​​they will request an AIDA64 report, video, images and a detailed history of the issue. Also, the support team may need traces, if so, they will ask you to install a special KIS version. 
  • After you submit the request, you’ll receive an automated email with an INC+12 digits reference #, then, normally, within 5 business days, a Kaspersky Lab human will contact you, also by email, you may continue to communicate with them via reply email & or by updating the INC in your MyKaspersky.com account.

Please let us know what they say?

Thank you:pray_tone3:

Flood:whale:

Kaspersky Internet Security for Android

I am having the same issue with my S20+

I have tried all the previous solutions, nothing helped

Userlevel 7
Badge +9

I am having the same issue with my S20+ I have tried all the previous solutions, nothing helped

 Hello @DBGT

Welcome!

  1. What happened when you setup the Internet protection wizard - post images so we can see what you see please? 
  2. Have you raised a case with the Technical Support team? If “no”, please contact Kaspersky Technical Support, ​​​​they will request an AIDA64 report, video, images and a detailed history of the issue. Also, the support team may need traces, if so, they will ask you to install a special KIS version. 
  3. After you submit the request, you’ll receive an automated email with an INC+12 digits reference #, then, normally, within 5 business days, a Kaspersky Lab human will contact you, also by email, you may continue to communicate with them via reply email & or by updating the INC in your MyKaspersky.com account.

Please let us know what they say?

Thank you:pray_tone3:

Flood:whale:+:whale2:

Kaspersky Internet Security for Android

Userlevel 1
Badge

I'm also dealing with that problem after upgrading to Android 10 last night. My Android smartphone is Realme 5 Pro running android 10.

 

Userlevel 7
Badge +9

I'm also dealing with that problem after upgrading to Android 10 last night. My Android smartphone is Realme 5 Pro running android 10.

 

Hello @Jassie_Dave

Welcome back! 

Before upgrading the android, from 9 to 10, did the “in-app links protection” issue exist? 

Make a video, of the process, where all permissions have been granted, see our reference video & post back please: 

 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Userlevel 1
Badge

Hello @Jassie_Dave

Welcome back! 

Before upgrading the android, from 9 to 10, did the “in-app links protection” issue exist? 

Make a video, of the process, where all permissions have been granted, see our reference video & post back please: 

 

 

Thank you so much @Flood and Flood's wife for always helping me, answering my questions. Yes, there’s no issue with Android 9. It was working just fine before i upgrade to 10

Here is a link I have created a video of the process. 

https://www.youtube.com/watch?v=H0adyVb4EYY

Userlevel 7
Badge +9

Thank you so much @Flood and Flood's wife for always helping me, answering my questions. Yes, there’s no issue with Android 9. It was working just fine before i upgrade to 10

Hello @Jassie_Dave

You’re most welcome, it’s always our pleasure to assist:relaxed:

Thank you for the video, excellent work:clap_tone3:

  1. 00:01, at that point, is KIS actually signed into (your) MyKaspersky account? 
  2. 00:15, KIS in Downloaded services, interesting, we would expect it to be in Installed services:thinking:
  3. 00:18, which was installed first, KIS or KSK? 
  4. 00:18, is phone/KSK used by parent or child? 
  5. 00:30+ Checking in-app links unavailable/Chrome, Set as default → Chrome, Use as default - are those two rectangles responsive to selection? 
  6. Since upgrading to v10, has KIS been uninstalled, the phone completely shutdown, powered off, restarted, logged in, new KIS downloaded & clean installed, phone completely shutdown, powered off, restarted, logged in?  
  7. After KIS was installed, were all steps in XIAOMI devices, initial setup implemented? 

Please let us know?

Thank you:pray_tone3:

Flood:whale:+:whale2:

Userlevel 1
Badge

 

  1. 00:01, at that point, is KIS actually signed into (your) MyKaspersky account? 
  2. 00:15, KIS in Downloaded services, interesting, we would expect it to be in Installed services:thinking:
  3. 00:18, which was installed first, KIS or KSK? 
  4. 00:18, is phone/KSK used by parent or child? 
  5. 00:30+ Checking in-app links unavailable/Chrome, Set as default → Chrome, Use as default - are those two rectangles responsive to selection? 
  6. Since upgrading to v10, has KIS been uninstalled, the phone completely shutdown, powered off, restarted, logged in, new KIS downloaded & clean installed, phone completely shutdown, powered off, restarted, logged in?  
  7. After KIS was installed, were all steps in XIAOMI devices, initial setup implemented? 

Thank you @Flood and Flood's wife 

  1. Yes, logged in
  2. My another device had KIS in “ Downloaded services” 
  3. KIS first
  4. Parent
  5. Yes, buttons are responsive (link to Kaspersky’s website).
  6. Not in the first place, so I tried following your guide but the problem still persists.
  7. Can’t tell ive reached that all settings :sweat_smile:  because some steps in the device's settings are different :disappointed_relieved:
Userlevel 7
Badge +9

Thank you @Flood and Flood's wife 

  1. Yes, logged in
  2. My another device had KIS in “ Downloaded services” 
  3. KIS first
  4. Parent
  5. Yes, buttons are responsive (link to Kaspersky’s website).
  6. Not in the first place, so I tried following your guide but the problem still persists.
  7. Can’t tell ive reached that all settings :sweat_smile:  because some steps in the device's settings are different :disappointed_relieved:

Hello @Jassie_Dave

Thank you:ok_hand_tone3:

Please share with us the Settings / options that are different? n

Thank you:pray_tone3:

Flood:whale:+:whale2:

I had the same problem. I thought perhaps having another (non supported) browser application installed could be the cause of the problem. I removed the DuckDuckGo browser (only other browser installed on my phone), this solved the problem for me. Phone restart might be required after uninstall, don't really remember, sorry. Hope it helps.

 

PS Obviously not a proper solution, but safety first I guess. Hopefully Kaspersky tech people can find the cause and solve this so I can install the DuckDuckGo browser again.

Userlevel 7
Badge +9

Hopefully Kaspersky tech people can find the cause and solve this so I can install the DuckDuckGo browser again.

Hello @RobertNL,

Welcome!

To test, we installed DuckDuckGo on three Androids, with different OS versions: 4.4, 7 & 10, there is no conflict, KIS installs correctly, In App Link protection works as per design. 

Note: DuckDuckGo is not supported by Kaspersky; if you choose to use it, it will not be monitored & or managed by the installed KIS application. 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Hopefully Kaspersky tech people can find the cause and solve this so I can install the DuckDuckGo browser again.

Hello @RobertNL,

Welcome!

To test, we installed DuckDuckGo on three Androids, with different OS versions: 4.4, 7 & 10, there is no conflict, KIS installs correctly, In App Link protection works as per design. 

Note: DuckDuckGo is not supported by Kaspersky; if you choose to use it, it will not be monitored & or managed by the installed KIS application. 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Thanks for your quick testing/response! :slight_smile:

I just did another check. I have KIS up and running without issues. I install DuckDuckGo and at first start it requests to select which browser to mark as default browser. Here I select Chrome. When I open KIS and refresh it (swipe down), it shows the issue again. Once I uninstall DuckDuckGo and refresh KIS the issue is gone/solved.

Same check with Firefox browser, no request to set default browser here but KIS shows issue here too. Uninstall Firefox and issue is gone.

Must be some obscure setting that makes the difference on my Note10 running Android 11. For now happy that security works, if I ever manage to figure out what setting causes the issue, I'll post it here.

Kind regards from the Netherlands.

Userlevel 7
Badge +9

Thanks for your quick testing/response! :slight_smile:

I just did another check. I have KIS up and running without issues.

I install DuckDuckGo and at first start it requests to select which browser to mark as default browser, Here I select Chrome. When I open KIS and refresh it (swipe down), it shows the issue again. Once I uninstall DuckDuckGo and refresh KIS the issue is gone/solved.

Must be some obscure setting that makes the difference on my Note10 running Android 11. 

For now happy that security works, if I ever manage to figure out what setting causes the issue, I'll post it here. Kind regards from the Netherlands.

Hello @RobertNL 

You’re most welcome:relaxed: !

Based on your reply, we tested installing DuckDuckGo v5.85.3zy, selecting Chrome as the default browser; KIS → In App Link protection configuration works exactly as designed - please see our video:

 

Thank you:pray_tone3:

Flood:whale:+:whale2:

Reply