Kaspersky
Solved

Ausnahmen für Verzeichnisse greifen nicht

  • 28 November 2020
  • 13 replies
  • 185 views

Kaspersky Internet Suite - registriert Vers. 21.2.16.590

Hallo, hat jemand eine Idee oder eine Lösung warum die angegebene Ausnahme Verzeichnisse nicht greifen?

 

Ich habe diverse Toolsammlungen und zudem das Verzeichnis einer meiner Dropboxen bei denen fälschlicher Weise direkt mal ohne Ende gelöscht wurde. Die Programme ließen sich auch nicht aus der Quarantäne zurück holen. Ich habe die relevanten Verzeichnisse als Ausnahmen hinzugefügt.

DAS greift aber nicht. Aus meiner Sicherung wieder hergestellt, wird alles direkt wieder gelöscht. Ich traue mich gar nicht meine Archivplatten anzuschließen.

Und ja, ich bin sicher es handelt sich NICHT um Viren.

Was muss man tun, damit Verzeichnisse die als Ausnahmen hinzugefüght wurden auch wirklich vom Virenscan ausgeschlossen bleiben?

 

Ich würde mich über Hilfe sehr freuen.  VG Steffix

icon

Best answer by Schulte 28 November 2020, 19:06

Mir fällt da gerade was ein:

Es war mal so, dass die Ausnahmen nur im interaktiven Modus greifen:

Dazu darf hier kein Haken gesetzt sein
 

 

In den Einstellungen für “Datei-Anti-Virus” gibt es dann die Option “Benutzer fragen”.

 

Der interaktive Modus bringt zusätzliche Nachfragen mit sich, z. B. bei der Installation von Programmen. Aber veruche es mal.

View original

13 replies

Userlevel 7
Badge +7

Hallo @Steffix, Willkommen.

Kannst Du uns bitte einen Screenshot von einer der angelegten Ausnahmen für ein Verzeichnis posten?

@Schulte Hallo, wow… Danke für die schnelle Reaktion… - es sollen alle Dateien und Unterverzeichnisse und auch in diesen enthaltenen Dateien, NICHT untersucht bzw. gelöscht werden. Die Syntax unter “Objekt” habe ich von einer Kasperski Info Seite. Habe aber auch * und *\ schon ausprobiert.

 

 

Nachtrag: ist jetzt natürlich nur beispielhaft eben angelegt. Die anderen Verzeichnisse befinden sich auf NAS Laufwerken. Eine Testdatei wird immer wieder gelöscht.

 

Danke und VG Steffix

Userlevel 7
Badge +7

Hallo @Steffix,

ändere bitte die Regel so ab:

Datei oder Ordner
C:\User\skolo\Downloads\zwi\*.*

Sollten in “zwi” enthaltene Unterverzeichnisse ebenfalls nicht untersucht werden, sieht das so aus:
C:\User\skolo\Downloads\zwi\**\*.*
(Beachte das doppelte “*”)

Objekt und Datei-Hash lässt Du leer

Ich hoffe, das funktioniert dann.

Mehr Lesestoff: https://support.kaspersky.com/KTS/21.2/de-DE/201385.htm

Hallo @Schulte … keine Chance. Datei wird sofort gelöscht von Kaspersky.

Wobei die Felder Objekt und Datei Hash habe ich leer gelassen, aber nach dem abspeichern steht dort jeweils ein Sternchen … also ein *

 

und jepp, die Seite meinte ich. Mit meinem Verständnis funktionieren die dort gemachten Angaben nicht. Vorbehaltlich eines dämlichen Fehlers von mir...

 

 

C:\User\skolo\Downloads\zwi\**\

und im Objekt: *.*

 

ebenfalls sofort gelöscht.

 

C:\User\skolo\Downloads\zwi\

und im Objekt: \**\*.*

ebenfalls sofort gelöscht.

 

Im Hash setzt Kaspersky jedes mal beim abspeichern ein * rein

 

Userlevel 7
Badge +7

Mir fällt da gerade was ein:

Es war mal so, dass die Ausnahmen nur im interaktiven Modus greifen:

Dazu darf hier kein Haken gesetzt sein
 

 

In den Einstellungen für “Datei-Anti-Virus” gibt es dann die Option “Benutzer fragen”.

 

Der interaktive Modus bringt zusätzliche Nachfragen mit sich, z. B. bei der Installation von Programmen. Aber veruche es mal.

Hallo Herr @Schulte … das wäre möglich, aber ich kann diese Option nicht finden. Wo genau finde ich die?   Habe meiner Ansicht nach jetzt alles durch. Finde nur nur diese hier...

 

 

Userlevel 7
Badge +7

Du musst zunächst unter “Einstellungen->Allgemein” den Haken bei “Empfohlene Aktionen automatisch ausführen” entfernen (und Speichern). Siehe mein erstes Bild.

@Schulte … Danke!! Ich war zu blöd auf show content zu klicken.

Okay, das funktioniert insofern, dass nicht mehr direkt gelöscht wird, mit erheblichen Rückfragen.

Ich muss das jetzt noch ausgiebig testen, bevor ich mein NAS Geschwader da dran hänge. Sonst habe ich ein ernsthaftes Problem :-)  - stimmt mich aber wieder optimistisch. War schon ganz frustriert. Ich wollte hier alles nämlich auf Kaspersky umstellen. Das wäre das KO Kriterium gewesen. Ich teste jetzt erstmal...

 

Ganz ganz herzlichen Dank für die Unterstützung an einem wertvollen Samstag Abend!

beste Grüße - Steffix

Userlevel 7
Badge +7

Hi @Steffix, gern geschehen.

Du kannst jetzt nochmal mit den Ausnahmen spielen.
Irgendwie sollten die Rückfragen verschwinden…

Viel Erfolg!

Die Ausnahmen haben wohl einen Effekt, aber die Performance ist da immer noch 100% langsamer als mit temporär komplett deaktivieren Kaspersky. Man sieht das der Service Prozess eine CPU zieht (was egal ist. Nur die Performance ist für mich wichtig).

 

Da ist Microsoft Defender besser. Wenn ich dort eine Ausnahme definiere, dann wird die Performance nicht mehr beeinträchtigt.

 

Kommandos:

 

$ time find . -name "*.ts" | wc
  78362   78365 7073018

real    0m6.190s
user    0m1.109s
sys     0m5.061s

 

Das ist immer gleich und ok.

 

Mit deaktiviereten Scanner bzw. mit Defender+Ausnahme:

$ time find . -name "*.ts" | xargs cat | wc
cat: ./frontend/node_modules/canvg/lib/Document/PathElement: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/canvg/lib/Document/TextPathElement: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/canvg/lib/PathParser: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/gl-matrix/types.d.ts: Is a directory
cat: ./frontend/node_modules/microevent.ts: Is a directory
cat: ./server/backend/node_modules/microevent.ts: Is a directory
4164933 19390058 170680701

real    0m11.718s
user    0m3.882s
sys     0m14.072s

 

Mit Scanner und ohne Ausnahme:

$ time find . -name "*.ts" | xargs cat | wc
cat: ./frontend/node_modules/canvg/lib/Document/PathElement: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/canvg/lib/Document/TextPathElement: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/canvg/lib/PathParser: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/gl-matrix/types.d.ts: Is a directory
cat: ./frontend/node_modules/microevent.ts: Is a directory
cat: ./server/backend/node_modules/microevent.ts: Is a directory
4164933 19390058 170680701

real    1m14.258s
user    0m3.773s
sys     0m17.830s

 

Mit Scanner und mit Ausnahme:

$ time find . -name "*.ts" | xargs cat | wc
cat: ./frontend/node_modules/canvg/lib/Document/PathElement: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/canvg/lib/Document/TextPathElement: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/canvg/lib/PathParser: No such file or directory
cat: copy.d.ts: No such file or directory
cat: ./frontend/node_modules/gl-matrix/types.d.ts: Is a directory
cat: ./frontend/node_modules/microevent.ts: Is a directory
cat: ./server/backend/node_modules/microevent.ts: Is a directory
4164933 19390058 170680701

real    0m29.226s
user    0m3.514s
sys     0m15.444s

 

Variiert von 29s bis 42s. 29s ist das Beste. 

 

 

Reply