Kaspersky
Question

Verstehe die Firewall der KIS nicht

  • 17 July 2019
  • 9 replies
  • 881 views

Hallo allerseits!

Nach sehr langer Abstinenz und zwischenzeitlichem "Überlaufen" zur G DATA IS wollte ich es mit folgendem System dann bis zum Supportende nochmals mit der KIS versuchen:

Win 7 Home Premium 64 Bit inkl. SP1
intel Core i7 2670QM
6 GB RAM
(falls noch Infos benötigt werden, bitte Bescheid geben)

Nachdem ich die G DATA IS über die Systemsteuerung entfernt hatte, habe ich nach einem Systemneustart noch 2x das G DATA eigene Entfernungstool ausgeführt (inkl. jeweiliger Neustarts).

Danach habe ich dann die Testversion der KIS (19.0.0.1088(d)) ausgeführt und war nach dem ersten Start gleich "erschlagen" und komplett überfordert.

In diesem Zusammenhang finde ich folgendes rätselhaft:

Auf meinem Laptop ist unter anderem das Garmin-Programm "Basecamp" installiert. Dieses hat momentan die Version 4.6.2; es existiert jedoch eine aktuellere Version (welche ich jedoch nicht installieren möchte!).

Da das Programm diese neue Version bei jedem Start stets automatisch herunterlädt, wollte ich dies im Vorfeld (wie auch schon über die G DATA Firewall) verhindern.

Unter "Schutz" -> "Firewall" -> "Regeln für Programm anpassen" - "Netzwerkregeln für Programme" war das Programm jedoch zu meinem Erstaunen gar nicht aufgeführt.

Also führte ich Basecamp einmal aus und danach wurde unter "Netzwerkregeln für Programme" das Programm "Garmin Corp." bzw. "BaseCamp Application" gelistet.

In diesem Zuge hatte Basecamp jedoch bereits wieder das Update im Hintergrund heruntergeladen und bot es zur Installation an (welche ich nicht durchführte).

Nun klickte ich doppelt auf "BaseCamp Application" und dann auf den Reiter "Netzwerkregeln".

Hier setzte ich hinter den 3 Adressen (Subnetzadressen - Vertrauenswürdiges Netzwerk, Subnetzadressen - Lokales Netzwerk und Subnetzadressen - Öffentliches Netzwerk) die Aktion "Aktion erfragen" uns wählte unten "Speichern".

Dann begab ich mich (wie unter "Aktion erfragen" angegeben) nach "Allgemein" und entfernte dort den Haken bei "Interaktiver Schutz" -> "Empfohlene Aktionen automatisch ausführen".

Bereits hier wurde ich stutzig: Schaltet man hier nicht bereits den gesamten Interaktiven Schutz ab, obwohl man ja eigentlich nur erwirken möchte, dass die "Firewall" nicht automatisch agiert, sondern nachfragt?

Jedenfalls startete ich danach nochmals Basecamp und sah zu meiner Freude, dass die KIS nachfragte (ich wählte "Dauerhaft merken" und "Verbieten") und das Update im folgenden nicht geladen wurde.

Testweise ging ich nun nochmals in die Netzwerkregeln und war etwas verblüfft:

Lediglich unter "Subnetzadressen - Öffentliches Netzwerk" war eine rotes Kreuz gesetzt - ich bin aber doch über WLAN mit einem "Vertrauenswürdigen Netzwerk" verbunden....

Bei den anderen beiden Subnetzadressen stand hingegen noch das orangefarbene Symbol/Fragezeichen.

Testweise ersetzte ich die Aktion bei "Subnetzadressen - Öffentliches Netzwerk" wieder durch "Aktion erfragen" und setzte beide anderen Adressen (Vertrauenswürdiges Netzwerk und Lokales Netzwerk) auf "Verbieten" und speicherte.

Nach einem Start von Basecamp wurde allerdings dann das Update erneut heruntergeladen!

Muss ich das verstehen?

Ich fühle mich irgendwie schon jetzt komplett überfordert....

Gruß,

Scyllo

9 replies

Also irgendetwas kann doch hier ganz und gar nicht stimmen...

Ich habe soeben meinen Laptop gestartet (zum 3. Mal heute) und nach der Anmeldung in meinem Benutzerkonto erschien plötzlich dieses Fenster:



Wieso bitte kommt hier eine Meldung seitens der Windows-Firewall?

Eigentlich dachte ich, dass die KIS diese Einstellungen verwaltet:



Wählt man allerdings auf der linken Seite "Erweiterte Einstellungen", so steht dort:



Sollte hier nicht eigentlich stehen, dass die Windows-Firewall ausgeschaltet ist?

So war es jedenfalls bei vorherigen Internet Security Suites.

Gruß,

Scyllo
Userlevel 7
Badge +6
Hi @Scyllo, zunächst mal ein "Willkommen zurück".

Hab' mir gerade mal einen älteren Rechner geschnappt (mit W7 HP) und KIS aufgespielt.
Ich kann Deine Beobachtung nicht nachvollziehen, bei mir ist die Win-Firewall deaktiviert. Ich habe die Vermutung, dass mit Deiner Installation etwas nicht stimmt. Gab es vom KIS-Installer irgendwelche Hinweise während der Installation?
Ich empfehle eine De-/Reinstallation (bei der Deinstallation nur die Aktivierungsdaten behalten, nichts anderes).

Zu Deiner Frage bezüglich der Firewalleinstellungen:
KIS unterscheidet hier nach der angefragten IP-Adresse, unabhängig vom Netzwerk.
Erkennt KIS eine Verbindung in's WWW (Dein Netz läuft sicher unter 192.168.X.X, einer privaten Range), ist das automatisch ein Zugriff auf ein "öffentliches Netzwerk". Um die Verbindung zum Internet für ein Programm zu blockieren genügt es, hier auf das rote "X" zu schalten. Auf das interne Netzwerk (falls vorhanden) hat das Programm weiterhin Zugriff, je nachdem wie Du es eingestuft hast. Dass sich Dein Rechner per lokalem oder vertrauenswürdigem Netz mit dem Internet verbindet, spielt hier keine Rolle.

Falls das jetzt zu technisch war: für den Zugriff auf's Internet musst Du nur "Subnetzadressen - Öffentliches Netzwerk" blockieren.

Wenn Du weitere Fragen hast, frag.
Hi @Scyllo, zunächst mal ein "Willkommen zurück".

Hallo @Schulte und danke für die Begrüßung!

Hab' mir gerade mal einen älteren Rechner geschnappt (mit W7 HP) und KIS aufgespielt.
Ich kann Deine Beobachtung nicht nachvollziehen, bei mir ist die Win-Firewall deaktiviert. Ich habe die Vermutung, dass mit Deiner Installation etwas nicht stimmt. Gab es vom KIS-Installer irgendwelche Hinweise während der Installation?
Ich empfehle eine De-/Reinstallation (bei der Deinstallation nur die Aktivierungsdaten behalten, nichts anderes).


Vielen Dank für die Mühe!

Also stimmt es, dass dort ("Systemsteuerung" -> "System und Sicherheit" -> "Windows-Firewall" -> "Erweiterte Einstellungen") unter den jeweiligen Profilen eigentlich stehen sollte, dass die Windows-Firewall deaktiviert ist?

Nein, vom KIS-Installer (ausgeführt im "Admin-Konto" als Administrator) gab es keine Hinweise während der Installation.

Ich muss aber dazu sagen, dass ich den Installer von der Kaspersky-Homepage (startup_14898.exe) verwendet hatte, da mir dessen Version (19.0.0.1088.0.3779.0 (a.b)) aktueller erschien als die von Dir verlinkte kis19.0.0.1088de_14081.exe (19.0.0.1088.0.106.0).

Zur Sicherheit habe ich nun aber nochmals die KIS komplett, wie von Dir beschrieben über die Systemsteuerung deinstalliert. Anschließend habe ich dann im abgesicherten Modus den aktuellen kavremover ausgeführt der aber kein installiertes Programm fand.

Leider kann man in diesem Zusammenhang nicht mehr (wie früher) auswählen, dass alle Programme (die je seitens Kaspersky installiert waren) entfernt werden sollen. Ich weiß nämlich leider nicht mehr, was meine letzte KIS auf diesem System war und welchen Eintrag ich nun auswählen sollte.

Ich startete das System neu und führte im Folgenden testweise den "Windows-Firewall-Fix" aus, den ich auf der Microsoft-Homepage fand: https://support.microsoft.com/de-de/help/17613/automatically-diagnose-and-fix-problems-with-windows-firewall

Dieser brachte lediglich diese Meldung:



Das wunderte mich!

Denn vor einiger Zeit hatte ich unter "Systemsteuerung" -> "System und Sicherheit" -> "System" -> "Remoteeinstellungen" den Haken unter "Remoteunterstützungsverbindungen mit diesem Computer zulassen" entfernt (und der Haken fehlt dort, wie ich soeben überprüfte, immer noch)!

Wie kann die Remoteunterstützung also angeblich noch aktiviert sein?

Ich klickte auf "Abbrechen" und installierte anschließend die KIS neu; dieses Mal aber mit dem von Dir verlinkte Installer kis19.0.0.1088de_14081.exe komplett neu.

Nach dem ersten Start der KIS (19.0.0.1088(d)) wählte ich Datenbanken-Update, da das automatische Update irgendwie sehr lang auf sich warten ließ und startete nach dem Update das System neu.

Angezeigt wurde nun KIS (19.0.0.1088(f)).

Ich begab mich wieder nach "Systemsteuerung" -> "System und Sicherheit" -> "Windows-Firewall" -> "Erweiterte Einstellungen", doch erneut stand unter den jeweiligen Profilen, dass die Windows-Firewall aktiviert sei!

So langsam bin ich etwas verzweifelt.....

Zudem ich auch folgendes seltsam finde: Weshalb findet die KIS nach ihrer Installation nicht automatisch alle auf dem System installierten Programme (wie z.B. sämtliche Programme von Garmin (unter anderem Basecamp)?

Wie ich bereits oben schrieb, tauchen unter "Regeln für Programme anpassen" (KIS-Firewall) keinerlei Einträge bezüglich Garmin auf.

Und wenn ich es grob überfliege, fehlen dort auch andere Programme.

Wie soll ich diesen Programme dann aber den "Kontakt" zum Internet untersagen, wenn ich diese erst starten muss und die Programme dabei aber bereits aus- und eingehenden Internetverkehr betreiben?

Muss man dafür im Vorfeld wirklich jedes Mal den "Interaktiven Schutz" unter "Allgemein" deaktivieren, damit die KIS im Folgenden für jedes Programm nachfragt?

Den Rest, den Du mir zu den Firewalleinstellungen (s.u.) geschrieben hast, muss ich mir erst noch einmal durchlesen; so ganz verstanden habe ich es nämlich nicht.

Muss ich der KIS schon jetzt wieder "Lebewohl" sagen?

Gruß,

Scyllo

Zu Deiner Frage bezüglich der Firewalleinstellungen:
KIS unterscheidet hier nach der angefragten IP-Adresse, unabhängig vom Netzwerk.
Erkennt KIS eine Verbindung in's WWW (Dein Netz läuft sicher unter 192.168.X.X, einer privaten Range), ist das automatisch ein Zugriff auf ein "öffentliches Netzwerk". Um die Verbindung zum Internet für ein Programm zu blockieren genügt es, hier auf das rote "X" zu schalten. Auf das interne Netzwerk (falls vorhanden) hat das Programm weiterhin Zugriff, je nachdem wie Du es eingestuft hast. Dass sich Dein Rechner per lokalem oder vertrauenswürdigem Netz mit dem Internet verbindet, spielt hier keine Rolle.

Falls das jetzt zu technisch war: für den Zugriff auf's Internet musst Du nur "Subnetzadressen - Öffentliches Netzwerk" blockieren.

Wenn Du weitere Fragen hast, frag.
Noch etwas:

Habe soeben mal unter "Systemsteuerung" -> "Programme deinstallieren" nachgesehen.

Dort fehlen seit heute sämtliche Details (Hersteller, Installationsdatum, Version, etc.) zu den installierten Programmen:



In den anderen Benutzerkonten auf dem Laptop ist dies nicht so!

So langsam bekomme ich hier die Krise.....

Es kann doch nicht sein, dass stets "auf meinem System" irgendetwas nicht läuft....

Gruß,

Scyllo
Userlevel 7
Badge +6
Hi Scyllo,

nur kurz zwischendurch:
mach bei den installierten Programmen mal einen Mausrechtsklick auf "Name" oder "Größe".

Melde mich später wieder
Hallo Schulte,

danke für Deine Geduld.

Ich habe jetzt erstmal wieder ein Backup eingespielt, auf welchem noch die G DATA IS installiert ist.

Hier sieht das Ganze so aus:



Auch die Anzeige bei den installierten Programmen ist wieder "normal".

Allerdings habe ich mit der G DATA Firewall und Windows 7 ein anderes Problem....

Darf ich dies hier mal schildern (auch wenn es Fremdsoftware ist), um das Problem, welches ich nun mit Kaspersky habe, eventuell eingrenzen zu können?

Gruß,

Scyllo

PS: Gerade eben war die Anzeige bei den installierten Programmen dann wieder urplötzlich "fehlerhaft", wie oben von mir beschrieben.

Ich habe aber nichts am Laptop verändert....

Wie von Dir geraten, habe ich dann mit Rechtsklick auf "Größe" geklickt und konnte dann die anderen "Reiter" (Hersteller, etc.) wieder anhaken.

Was bitte ist denn da los.....?

Warum ist deren Anzeige zwischenzeitlich einfach so verschwunden?
Userlevel 7
Badge +6
Wie soll ich diesen Programme dann aber den "Kontakt" zum Internet untersagen, wenn ich diese erst starten muss und die Programme dabei aber bereits aus- und eingehenden Internetverkehr betreiben?

Muss man dafür im Vorfeld wirklich jedes Mal den "Interaktiven Schutz" unter "Allgemein" deaktivieren, damit die KIS im Folgenden für jedes Programm nachfragt?

Nein, es geht auch anders: Wie kann ich die Berechtigungen für ein Programm vor dessen erstem Start einstellen?

Darf ich dies hier mal schildern (auch wenn es Fremdsoftware ist), um das Problem, welches ich nun mit Kaspersky habe, eventuell eingrenzen zu können?
Wenn Du Dich aufs Wesentliche beschränkst und den Firmannanmen nicht so oft nennst, gerne.

Warum ist deren Anzeige zwischenzeitlich einfach so verschwunden?
Kann ich Dir leider nichts dazu sagen...
Hallo Schulte!

Das "Problem" hinsichtlich der "Software-deren-Namen-nicht-genannt-werden-darf"😉 ist das folgende:

Dieses Programm zeigt in der "Taskbar Notification Area" (unten rechts) über ein Symbol/Icon den aktuellen Status der Internet Security an (wie bei Kaspersky auch).

Per Rechtsklick auf dieses Icon lassen sich im Folgenden einzelne Schutzkomponenten temporär oder dauerhaft "deaktivieren": Firewall und deren Autopilot sowie der Wächter/Echtzeitschutz.

Hinsichtlich des Wächters funktioniert dies auch tadellos: deaktiviere ich diesen per Rechtsklick, so wird mir dies anschließend auch in der GUI der Sicherheitssuite korrekt angezeigt (Ihr System ist gefährdet: Virenwächter aus)!

Ebenso erhält das Icon in der Taskbar Notification Area ein Warndreieck mit Ausrufezeichen.

Führe ich das Ganze jedoch bezüglich der Firewall aus, so erhält das Icon in der TNA zwar auch das Warndreieck mit Ausrufezeichen, allerdings wird die "Deaktivierung" nicht in der GUI angezeigt.

Man weiß also gar nicht sicher, ob die Firewall nun überhaupt deaktiviert wurde oder nicht.

Als ich mich an den Support wandte, sagte man mir, dass wohl "irgendwie" der Prozess AVKTray.exe zum Absturz gebracht würde (der aus den eingesendeten Absturzprotokollen ersichtliche Fehlercode lautete 0xc0000005).

Da ich aber ja nun auch in Verbindung mit der aktuellen KIS Probleme im Zusammenhang mit der Firewall-Verwaltung zu haben scheine, frage ich mich, ob irgendetwas mit der Windows-Firewall nicht stimmt.

Deswegen hatte ich ja auch den Microsoft-Fix ausgeführt; aber da wird (außer dem Hinweis zur Remoteunterstützung (die ich aber ja auch deaktiviert haben möchte!)) kein Fehler gefunden.

Auch die Überprüfung sfc /scannow, chkdsk c: /f /r oder dism/Online/Cleanup-Image/ScanHealth (alles vom Support empfohlen) brachten keine neue Erkenntnis!

Das Problem, dass die Windows-Firewall bei mir unter Kaspersky nicht deaktiviert zu sein scheint, hatte ich damals auch schon einmal mit der Fremdsoftware erlebt; dafür gab es dann seitens des Herstellers einen Fix.

Eigentlich würde ich gerne wieder die KIS nutzen, fahre aber in wenigen Tagen in den Urlaub und habe nur sehr wenig Zeit, immer neue Varianten (inkl. Installation/Deinstallation, Bereinigung, Backup-Anfertigung, etc.) auszuprobieren.

Zumal läuft übermorgen die Lizenz des anderen Herstellers aus und ich muss mich nun schnell für irgendeinen Anbieter entscheiden.

Ist das Alles nur ein Anzeigeproblem oder gibt es nun wirklich Probleme auf meinem System mit der Firewallfunktion (unter beiden Anbietern) selbst?

Und bringen beide Anbieter eine eigene, wirklich Software-Firewall mit oder wird jeweils immer nur die Windows-Firewall "verwaltet"?

Gruß,

Scyllo
Userlevel 7
Badge +6
Hi @Scyllo,

mit Deiner Fehlerbeschreibung muss ich erst mal ein wenig beschäftigen.
Verdächtig ist es schon, wenn Du mit zwei unterschiedlichen Produkten Probleme mit der Win-FW hast...

Zum Punkt eigene Firewall: die ist bei KL prinzipbedingt Voraussetzung, sonst würde z. B. das HIPS nicht funktionieren.

Der Rest, wie gesagt, später.

Reply / Ответить